Can't enable CORS


#1

In ownCloud 10.0.8, I’m trying to enable CORS, but when I try to whitelist the domain, it just fails with no error. I think is because my ownCloud server currently does not have a domain name, I only access it through a public IP address. Can anyone confirm that CORS only works if your server has a domain name?


#2

You should add http:// or https:// at the beginning of your domain name. If you already did, can you share domain name with us?


#3

Ah thank you, it does accept it when I add the https. However, I’m still getting this error from my app:
No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'https://llamafilm.zendesk.com' is therefore not allowed access. The response had HTTP status code 401.
Do I have to restart the server after modifying this setting?