Can't find theme in Admin dashboard

Hi there,
I was performing all steps as described in Theming ownCloud :: ownCloud Documentation
I’m stucking at 2. Enable the theme in the ownCloud Admin dashboard., because I can’t find it in Admin dashboard.
The Theme-App is listed in Apps, but nothing more.
What to do?

Regards,
Ben

Then is is not loaded. Usually, owncloud.log might know more about the why.

Hi ben-xs,

you should find your theme in disabled apps (enable it there), then it should show up in enabled apps.

The documentation is wrong. There is no admin dashboard in ownCloud.

FYI: I filed an issue to have this fixed

But

  • Any theme is an app.
  • My theme-abu was enabled and listed out of the box at Settings->Apps.

Hey guys, thx for your fast reply.
My theme-app is already enabled.
For example the background.jpg for the login-page is not displayed.
How does owncloud know to use this theme?

Correct. but there is no admin dashboard. This is the apps panel :slight_smile: The documentation is wrong here.

@ben-xs Did you follow the instructions at How to Change the Login Background Image?
Ist the file readable by your webserver user?

There is an example theme as well, maybe you want to try this out to get deeper insights: https://github.com/owncloud/theme-example/

@cortho I used the example theme (only changed the name). So there should be a new background image. The folder, subfolders and files are owned by the webserver user.
But again the question, how does owncloud know to use the styles.css from my app?

By enabling the theme (which is a special app) ownCloud knows, when loading the apps, that there is a theme present. There can only be exactly one theme enabled.

When you have got the file core/css/styles.css in your theme this will be loaded after owncloud’s style.css, so there you can override css properties.

Common pitfalls with themes:

  • Clear the browser cache else outdated contents might be shown
  • If you have configured a local memcache in config.php make sure it is working. If not sure, comment out the line with 'memcache.local' for testing purposes

My browser cache is cleared, this is the first thing I do, after changing something in css.
Local memcache is now disabled, but still nothing to see from the theme.

Once again, my theme is listed as an app and enabled.
The folder of the app is located in apps-external as a subfolder of the ownload root directory.
All folders, subfolders and files are owned by the webserver user.
The info.xml from the app has declared at types <theme/>.

Strange! Did you also check owncloud.log for related errors? What browser are you using? Did you check browser console?

Yes I’ve checked owncloud.log. There I have some errors
“Trusted domain error” and
“Could not resolve OCA\\Activity\\BackgroundJob\\EmailNotification! Class OCA”
“Could not resolve OCA\\Activity\\BackgroundJob\\ExpireActivities! Class OCA”
Nothing with the appid of my theme.

I’m using Firefox, but also Chrome doesn’t show the theme.
Browser Console says for background image
https://myowncloud.mydomain.com/core/img/background.jpg

Did you changed both, the name of the folder and the name of the app in your-theme/appinfo/info.xml?

Please try to disable the theme, rename the folder to another name and also change the <id> to that folder name. Enable the theme again afterwards.

Yes, the foldername and app-id is the exactly same.
But this is crazy, I’ve renamed the folder and id as sugested and now the theme works. By rename it back, the theme is not working again.
I don’t know why, but with the new name it works. Thank you!

1 Like

Good to hear that it is working now. It is very important that you changed both before you enable the app. Maybe there was the mistake.

Yeah, very good.
I’m sure I’ve enabled the app after changing foldername and appid.