Can't install. 403 forbidden

installation
9.1.x
help

#1

Hi!
Installing today from the latest setup-owncloud.php to make a fresh 9.2 install:

After the screen for creating admin username password, index.php is loaded and a 403 forbidden page is shown.
You can go back to index.html and re-enter a new admin username and database info, and after it you return to the 403 forbidden page again.

ALSO, the setup-owncloud.php script is intended to check for dependencies, but no warning is shown about my posgresql being too old.
tested with both php 5.6 and 7.0


#2

Hi,

a 403/forbidden is something were your webserver is responsible for. Dig into its config and also check the logfiles of your webserver.

If you think oC should warn you about that (for whatever reason) please post this to the bugtracker [1]. This won't be noticed in here and will definitely get lost.

[1]


#3

According to description, "The Web Installer is the easiest way to install ownCloud on a web space. It checks the dependencies, downloads ownCloud from the official server, unpacks it with the right permissions and the right user account. "
That's why I deleted my 8.1 install and started again from a fresh 9.1 web installer, just to see it did not check dependencies nor unpack it with right permissions.


#4

If ownCloud is checking the dependencies but not the web installer and you're expecting that the webinstaller is doing double work -> https://github.com/owncloud/administration/issues/new

There is nothing what we users in here can do about that (IMHO the webinstaller should be just dropped as people should be capable to extract a archive on their own).

Unpacking is done via the permissions of the webserver / PHP with the set umask of your system. So this is again an issue of your setup / PHP / webserver / whatever if the permissions where wrong after the installation.


#5

OK, so all the blah blah blah in owncloud page about the convenience of using the installer is simply propaganda. If I had known it, I had used my own "download script from web and install it" php script.

BTW I have solved the issue re-installing 8.0.1 (I wonder why I can't install 8.1.x now). I will try to overwrite it with 9.x.
I also compare the htaccess file made by 8.0.1 with the one made by 9.x, just in case that is what causes the problem.
8.0.1 lacked the following lines:
IfModule mod_env.c>
# Add security and privacy related headers
Header set X-Content-Type-Options "nosniff"
Header set X-XSS-Protection "1; mode=block"
Header set X-Robots-Tag "none"
Header set X-Frame-Options "SAMEORIGIN"
Header set X-Download-Options "noopen"
Header set X-Permitted-Cross-Domain-Policies "none"
SetEnv modHeadersAvailable true

Maybe these were the ones disallowing me from installing owncloud inside a sub domain in a shared host. But I swear I tried deleting the whole .htaccess before posting here.

PS -- having a history list of owncloud releases on the webpage would be useful for those, as me, having to roll back to very old releases and updating them before. I had had to made a php script to detect all releases between 8.0.1 and 9.1 and update my install (8.0.1 did not allow for auto updates).


#6

Its just for the users not able to simple download and extract an archive on their own. :slight_smile: As written above:

(IMHO the webinstaller should be just dropped as people should be capable to extract a archive on their own).

That would be the best way from my PoV.

https://owncloud.org/install/#edition -> Looking for older versions or major releases? -> https://owncloud.org/changelog/ -> Profit


#7

Thanks. I was unable to see the link in the owncloud page.

Now I'm updating upwards. I'm on 9.0.7 yet, and I hope I could update to 9.1 in ten minutes.


#8

OOH!

I can't believe Owncloud 9.1.x relies on shell access to update itself!! most shared hosting sites do NOT allow shell access from php!!

Things to share with devteam / bug report:
- 403 forbidden on new install on shared hosting, maybe caused by anti-xss.
- Softaculous CAN'T install 8.1.x-9.1.x if not installed before. Ends with error.
- beginning with 9.1.x, update engine relies on access to the occ script from php.


#9

You don't want to run ownCloud on a shared hosting.