Can't login from loging page


#1

Hello,

installed ownCloud on centos 6 without any erorr but when I go to loging page docs.mobilecenter.lt and try to login it just do nothing. Neither the login button nor the enter key is working.

Any ideas why?


#2

Hello,

try restarting. If it does not help - how did you install ownCloud?

Did you read the documentation? https://doc.owncloud.com/server/9.1/admin_manual/installation/


#3

restarted Apache but it doesn't helped. And installed it using installation wizard (uploaded files to server and run it).


#4

Uploaded which files and run what?

Did you follow the installation path that is being documented in the documentation?

https://doc.owncloud.com/server/10.0/admin_manual/installation/

I suspect that you are lacking some modules that are needed for owncloud to work, or that you did not give your web server the permissions to your owncloud directories.

The more I know the better I can help you


#5
  1. dowloaded instalation file ( v10.0.2) from owncloud.org
  2. uploaded and extracted it on docs.mobilecenter.lt
  3. entered docs.mobilecenter.lt and filled the data needed into the installation wizard window. pressed the Finish or Install button (can't remember)
  4. Enterd docs.mobilecenter.lt again and now I have login forma that I can't use

Any thing additional I need to setup?


#6

You, as far as I know, just installed the core, without any dependencies.
You need a LAMP setup, and php modules.

https://doc.owncloud.com/server/10.0/admin_manual/installation/source_installation.html#install-the-required-packages

https://doc.owncloud.com/server/10.0/admin_manual/installation/source_installation.html#manual-installation-on-linux


#7

installed all required extensions but the result is same.

The I checked the page HTML code and found that the submit button has disabled="disabled" (<input type="submit" id="submit" class="login primary icon-confirm" title="Log in" value="" disabled="disabled">) and I deleted it. Then I could login, but now the problems is that all the links/buttons in admin's page has no links (href="#").


#8

could you make a fresh install following the documentation?

I don't know what you did exactly, in what order, and what could gone wrong.


#9

I did the following search here: https://central.owncloud.org/search?q=login%20button%20disabled and found https://central.owncloud.org/t/owncloud-login-button-wont-work-and-files-after-login-wont-shows-up-also/1707


#10

Definetly this is some kind of problem with javascript but can't find what cousing it and what I should disable. Any ideas?


#11

I still don't get how you installed your ownCloud.

With "installation file" you mean the tarball, right?

But if you just copy the tarball to your server and extract it, you still don't have all the dependencies needed for ownCloud. The database, the php modules, the Apache server.

Or did you install ownCloud from repositories? That's a different kind of installation


#12

Apache, data base, php modules and ll dependences was already installed (I use virtual server and virtualmin). So, I created new virtual server (with php, apache, data base, etc) for ownCloud and then uploaded the "ownCloud Server Archive File", extracted it, opened in browser and pressed pressed FINISH instalation. No errors. The tables in data base was created. Now I am able to open the login page but the login input (button) is disable='disabled'.

When I delete (using Chrome's Inspect funccion) the disable='disabled' from input I am able to log in but have blank content with all links disabled.


#13

can you show me your config.php thats in /var/www/owncloud/config/ directory?

also does the owncloud.log say anything?


#14

in my case the config.php is in /home/docs/public_html/config

<?php
$CONFIG = array (
'instanceid' => '---',
'passwordsalt' => '---',
'secret' => '---',
'trusted_domains' =>
array (
0 => 'docs.mobilecenter.lt',
),
'datadirectory' => '/home/docs/public_html/data',
'overwrite.cli.url' => 'http://docs.mobilecenter.lt',
'dbtype' => 'mysql',
'version' => '10.0.3.3',
'dbname' => 'name',
'dbhost' => 'localhost',
'dbtableprefix' => 'oc_',
'dbuser' => 'user',
'dbpassword' => '---',
'logtimezone' => 'UTC',
'installed' => true,
);

i had changed some security sensitive data (passwords, secret keys, db names and usernames)

By the way, I get pleanty of this kind of errors on Chrome Inspector:

Refused to execute script from 'http://docs.mobilecenter.lt/---some-script-name---.js?v=---' because its MIME type ('text/js') is not executable, and strict MIME type checking is enabled.

And here is the log file owncloud-log.txt (29.3 KB)


#15

Can't figure out what's wrong. Your logs are flooded with the "fall back" something error. Apart from a trusted domain error and an undefined variable I can't see any problems.

Your config.php looks fine, too.

maybe @tom42 can find something


#16

any ideas how to solve it? Stuck with this problem and can't valuate the script to see if it's right product to go Enterprise.


#17

This is a server configuration issue. Please search the web on howto configure mimetypes in apache,
e.g. like this https://serverfault.com/questions/405229/apache-delivering-css-and-js-files-but-browsers-dont-render-them


#18

can't understand where is the problem. In mime file I have text/javascript and text/js enabled, but when the page loads i get these errors. But it's stange as we have file oc.js in header Content-Type:text/javascript and this one shows no error, and lot of files that in header has Content-Type:text/js and all of them has errors, but as I mentioned before, both mime types text/javascript and text/js are listed.

Any ideas?


#19

text/js is not allowed by the browser - just get rid of it and make sure your server transmits them as text/javascript


#20

Can't find the way how to do that as it. I use virtualmin on Centos 6.