Can't login on client after upgrade to 10.0.4

upgrade
10

#1

Expected behaviour

User should be able to login using the MacOS Desktop Client (2.3.4) or iOS app.

Actual behaviour

Since i updated my Owncloud server to 10.0.4 the desktop client and iOS app won't login. It says the credentials are wrong. However they haven't changed since the upgrade. I still can login to Owncloud on the web interface.

Steps to reproduce

  1. Upgrade Owncloud from 10.0.3 to 10.0.4
  2. Retype user credentials on desktop client on MacOS or iOS

Server configuration

Operating system: Qnap's modified linux.

Web server: Apache 2.4.23

Database: 5.5.57-MariaDB

PHP version: 5.6.31

ownCloud version: 10.0.4

Storage backend (external storage):

Client configuration

Client version: 2.3.4

Operating system: MacOS

OS language: English

Qt version used by client package (Linux only, see also Settings dialog):

Client package (From ownCloud or distro) (Linux only):

Installation path of client:

Logs

Please use Gist (https://gist.github.com/) or a similar code paster for longer
logs.

Template for output < 10 lines

  1. Client logfile:

01-01 11:42:18:416 240333 OCC::AccountManager::saveAccount: Saving account "https://owncloud.kensentme.nl:8081/owncloud"
01-01 11:42:18:417 240333 OCC::AccountManager::saveAccountHelper: Saving 0 unknown certs.
01-01 11:42:18:420 240333 OCC::AccountManager::saveAccountHelper: Saving cookies. "/Users/jeroenvandenieuwenhof/Library/Application Support/ownCloud//cookies0.db"
01-01 11:42:18:421 240333 OCC::CookieJar::save: "/Users/jeroenvandenieuwenhof/Library/Application Support/ownCloud//cookies0.db"
01-01 11:42:18:422 240333 OCC::AccountManager::saveAccount: Saved account settings, status: 0
01-01 11:42:18:423 240333 OCC::HttpCredentials::fetchFromKeychain: -------- -----> QSslCertificate("", "", "1B2M2Y8AsgTpgAmY7PhCfg==", (), (), QMap(), QDateTime( Qt::TimeSpec(LocalTime)), QDateTime( Qt::TimeSpec(LocalTime))) QSslKey(PrivateKey, OPAQUE, -1)
01-01 11:42:18:424 240333 OCC::FolderMan::slotAccountStateChanged: Account "jeroen@owncloud.kensentme.nl:8081" disconnected or paused, terminating or descheduling sync folders
01-01 11:42:18:424 240333 OCC::PropfindJob::finished: PROPFIND request not successful, http result code is 0 ""
01-01 11:42:18:425 240333 OCC::ConnectionValidator::slotAuthFailed: QNetworkReply::NetworkError(OperationCanceledError) "Operation canceled"
01-01 11:42:18:425 240333 OCC::ConnectionValidator::slotAuthFailed: ******** Password is wrong!
01-01 11:42:19:774 240333 OCC::AccountState::setState: AccountState state change: "Configuration error" -> "Signed out"
01-01 11:42:19:776 240333 OCC::FolderMan::slotAccountStateChanged: Account "jeroen@owncloud.kensentme.nl:8081" disconnected or paused, terminating or descheduling sync folders

  1. Web server error log:

  2. Server logfile: ownCloud log (data/owncloud.log):
    {"reqId":"5jAsudMsXvfeqKSIqW8I","level":3,"time":"2018-01-01T10:46:13+00:00","remoteAddr":"82.161.236.96","user":"--","app":"PHP","method":"PROPFIND","url":"\/owncloud\/remote.php\/webdav\/","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at \/share\/CE_CACHEDEV1_DATA\/Web\/owncloud\/lib\/composer\/patchwork\/utf8\/src\/Patchwork\/Utf8\/Bootup\/intl.php#18"}
    {"reqId":"jJr3CogrtgQiwlxGCsff","level":3,"time":"2018-01-01T10:46:22+00:00","remoteAddr":"82.161.236.96","user":"admin","app":"PHP","method":"GET","url":"\/owncloud\/ocs\/v2.php\/apps\/notifications\/api\/v1\/notifications?format=json","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at \/share\/CE_CACHEDEV1_DATA\/Web\/owncloud\/lib\/composer\/patchwork\/utf8\/src\/Patchwork\/Utf8\/Bootup\/intl.php#18"}


#2

I had a problem on a linux desktop that seems very similar to yours. The client couldn't connect to the server (conflicting versions). Had to change from owncloud client to nextcloud client. Now it works. Maybe you want to try?

Killerkaninchen


#3

Thanks for your reply. I tried using the Nextcloud iOS app to connect to my server. Sadly it fails with error 401. Probably because it doesn't think my username/password is correct.