Can't login to ownCloud with Desktop app (Clean Install)

hosting

#1

Yesterday I had an issue with syncing to ownCloud with the desktop app, I spent too long trying to fix it so I figured I’d just delete the whole account and start from scratch again.

I removed absolutely everything, database, files, even recreated the cPanel account to illuminate a Permissions plausibility.

Now that I have a clean install, I still can’t connect to the server, I’m getting the same old message.
“Access forbidden by server” and then asks me to login via the browser instead.

I have honestly tried by best to find a fix for this but I have not been able to fix this.

Here is the output of my log.

{"reqId":"WwuuZi2mRp6dqdotUX47UgAAAAA","level":3,"time":"2018-05-28T07:23:18+00:00","remoteAddr":"49.194.48.2","user":"Petru","app":"PHP","method":"GET","url":"\/index.php\/settings\/personal?sectionid=security","message":"Argument 3 passed to OC\\Settings\\Panels\\Admin\\Certificates::__construct() must implement interface OCP\\ICertificateManager, null given, called in \/home\/cloud\/public_html\/lib\/private\/Settings\/SettingsManager.php on line 281 and defined at \/home\/cloud\/public_html\/settings\/Panels\/Admin\/Certificates.php#41"}

I have checked the files specified and cannot find an issue. I believe it might have something to do with my web server, but I have tripple checked the configurations and compared it with my old server “Where ownCloud” was never a problem, and I can’t find an explination.

I am running an AWS EC2 with WHM/CentOS7


#2

Please, always fill the issue template. You can add any additional information that you think it’s relevant before or after the template.

The problem might be already solved in a newer version, or you might have changed some code that could have broken ownCloud.

It seems the problem is in the server, but with the current information it isn’t enough to know where the problem is.
Also check if you can access to your ownCloud normally via the web interface, specially to the admin settings. The log is complaining about a “Certificates” panel there.