Can't login with some users. Fresh install


#1

Steps to reproduce

  1. Go to http://localip/owncloud
  2. Input admin/pass, enter
  3. Go to admin > users
  4. Input name, email, select group ‘users’ then hit “create”
  5. Alter the new user password and try to login on anonymous or normal tab (Google chrome)
  6. Incorrect password.

Expected behaviour

Login with any user

Actual behaviour

Can login with both admin and the first user I created, but the other two users I created give me “Incorrect password.”

Server configuration

Operating system:
CentOS 7.6.1810

Web server:
Apache 2.4.6

Database:
MySQL 5.6.43 Community

PHP version:
PHP 5.6.40

ownCloud version: (see ownCloud admin page)
ownCloud 10.0.10 (stable)

Updated from an older ownCloud or fresh install:
Fresh install

Where did you install ownCloud from:
http://download.owncloud.org/download/repositories/10.0/owncloud/ and choose “CentOS”

Signing status (ownCloud 9.0 and above):
No errors have been found.

The content of config/config.php:
https://pastebin.com/FdvQsu92

List of activated apps:

sudo -u apache php occ app:list

Enabled:

  • comments: 0.3.0
  • configreport: 0.1.1
  • dav: 0.4.0
  • encryption: 1.3.1
  • federatedfilesharing: 0.3.1
  • federation: 0.1.0
  • files: 1.5.1
  • files_external: 0.7.1
  • files_sharing: 0.11.0
  • files_trashbin: 0.9.1
  • files_versions: 1.3.0
  • files_videoplayer: 0.9.8
  • firstrunwizard: 1.1
  • market: 0.3.0
  • notifications: 0.3.5
  • provisioning_api: 0.5.0
  • systemtags: 0.3.0
  • updatenotification: 0.2.1
    Disabled:
  • external
  • user_external

Are you using external storage, if yes which one: local/smb/sftp/…
I added one, but I’m not using it yet.
smb/cifs 10.1.1.5/owncloud

Are you using encryption: yes/no
Yes, with recovery key

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…
Not that I’m aware

LDAP configuration (delete this part if not used)

There are no commands defined in the “ldap” namespace.

Client configuration

Browser:
Google chrome 71.0.3578.98 (32 bits)

Operating system:
Windows 10 Pro 1809 (32 bits)

Logs

Web server error log

None

ownCloud log (data/owncloud.log)

{"reqId":"XFnnb21szzdzKDJpqL4MTQAAAAU","level":2,"time":"2019-02-05T19:43:43+00:00","remoteAddr":"10.1.1.101","user":"--","app":"core","method":"POST","url":"\/owncloud\/index.php\/login?user=arthur","message":"Login failed: 'arthur' (Remote IP: '10.1.1.101')"}

#2

Ok, I just found out that the new accounts are using the admin password, even though I set (multiple times) another password). Bug maybe?


#3

I have verified this. It’s not possible, without logging out from the other session, unless you create a new window. But is this considered a bug? I don’t think so.


#4

I’m sorry, which part? Altering the password or loging into another account via anonymous tab?

I created and altered the user password here:


Then I opened an anonymous tab and it offered to login again. I tried with user arthur and the new password. It didn’t work. So I tried with my admin password and it worked. That’s what I’m finding strange.


#5

Yes, this sounds indeed very strange. I think I did exactly the same as you did. But here it worked as expected (Firefox).

Did you see the yellow notification on top, something like “Password successfully set”?


#6

Hmm… not that I remember.

BTW, it delays for like 1 second after hitting “create”. Is that normal? Maybe there is the issue.


#7

I don’t think that this one second is a problem, as the creation of new users works. But the password change, the lack of the notification, there is something wrong. Maybe you should skim the owncloud.log for that.