Can't read files via web-interface

I’m preparing to move my owncloud server to new hardware.
I’m using a test-server to test the migration, but I’m having problems.
My test-server runs ubuntu 20.04LTS, the database is MariaDB, php 7.4 (all stock ubuntu packages).
I installed OC, community version.
I created a backup of my production server’s database and restored it to the test-server.
I restored a backup of the data-files to a data-directory of the test-server.
I modified config.php of the production-server to the test-server to be usable for the test-server.
When I go to the web-page of the test-server, I can login, as root and as user. I think I’m seeing all files.
The problem is that I can’t read the files. When I try to open ownCloudUserManual.pdf, I get a message :

PDF.js v2.10.0 (build: c7a10e4)
Bericht: Missing PDF "http://cloud-test2/remote.php/webdav/ownCloudUserManual.pdf".

When I try to open/download example.odt I get a message :

## **Not Found**

## **Technische details**

* Extern adres:
* Aanvraag ID: XzgPWXqhofI52mRDE3IX

I found a post in this forum to test the data-directory like this :
sudo -u www-data touch /data/owncloud/user/documents/testfile
That works fine, also all directories leading up to that testfile are writable in the same way.
The pdf is where it should be, just like the odt-file (example files of owncloud).
I tried to look in the logging, but I can’ find anyhing usable.

Any ideas what is happening ? Or how to debug this ?
I didn’t try the client because I think the web-interface should work first.

Server configuration

Operating system:
Ubuntu 20.04.6 LTS
Web server:
Apache version 2.4.41
MariaDB version 10.3.39
PHP version:
ownCloud version: (see ownCloud admin page)
Updated from an older ownCloud or fresh install:
fresh install
Where did you install ownCloud from:
Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
paste the results into and puth the link here.

No errors have been found.

The content of config/config.php:

Is it OK to post that here ? The file has more than 7000 lines.

List of activated apps:

  - activity:
    - Version: 2.7.2
    - Path: /var/www/owncloud/apps/activity
  - calendar:
    - Version: 2.0.0
    - Path: /var/www/owncloud/apps/calendar
  - comments:
    - Version: 0.3.0
    - Path: /var/www/owncloud/apps/comments
  - configreport:
    - Version: 0.2.2
    - Path: /var/www/owncloud/apps/configreport
  - contacts:
    - Version: 1.5.5
    - Path: /var/www/owncloud/apps/contacts
  - dav:
    - Version: 0.7.0
    - Path: /var/www/owncloud/apps/dav
  - diagnostics:
    - Version: 0.2.0
    - Path: /var/www/owncloud/apps/diagnostics
  - federatedfilesharing:
    - Version: 0.5.0
    - Path: /var/www/owncloud/apps/federatedfilesharing
  - files:
    - Version: 1.6.0
    - Path: /var/www/owncloud/apps/files
  - files_external:
    - Version: 0.9.0
    - Path: /var/www/owncloud/apps/files_external
  - files_mediaviewer:
    - Version: 1.0.5
    - Path: /var/www/owncloud/apps/files_mediaviewer
  - files_pdfviewer:
    - Version: 1.0.2
    - Path: /var/www/owncloud/apps/files_pdfviewer
  - files_sharing:
    - Version: 0.14.0
    - Path: /var/www/owncloud/apps/files_sharing
  - files_texteditor:
    - Version: 2.6.1
    - Path: /var/www/owncloud/apps/files_texteditor
  - files_trashbin:
    - Version: 0.9.1
    - Path: /var/www/owncloud/apps/files_trashbin
  - files_versions:
    - Version: 1.3.0
    - Path: /var/www/owncloud/apps/files_versions
  - firstrunwizard:
    - Version: 1.3.0
    - Path: /var/www/owncloud/apps/firstrunwizard
  - gallery:
    - Version: 16.1.2
    - Path: /var/www/owncloud/apps/gallery
  - market:
    - Version: 0.8.0
    - Path: /var/www/owncloud/apps/market
  - notifications:
    - Version: 0.6.0
    - Path: /var/www/owncloud/apps/notifications
  - provisioning_api:
    - Version: 0.5.0
    - Path: /var/www/owncloud/apps/provisioning_api
  - systemtags:
    - Version: 0.3.0
    - Path: /var/www/owncloud/apps/systemtags
  - templateeditor:
    - Version: 0.5.0
    - Path: /var/www/owncloud/apps/templateeditor
  - twofactor_totp:
    - Version: 0.9.0
    - Path: /var/www/owncloud/apps/twofactor_totp
  - updatenotification:
    - Version: 0.2.1
    - Path: /var/www/owncloud/apps/updatenotification
  - encryption:
    - Path: /var/www/owncloud/apps/encryption
  - external:
    - Path: /var/www/owncloud/apps/external
  - federation:
    - Path: /var/www/owncloud/apps/federation
  - user_external:
    - Path: /var/www/owncloud/apps/user_external

Are you using external storage, if yes which one: local/smb/sftp/…
Are you using encryption: yes/no
Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…

Client configuration

Firefox 123
Chromium 122
Operating system:
Linux kubuntu 22.04 LTS


Web server error log


ownCloud log (data/owncloud.log)

more than 32MB, post here ?

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log

b) The network log 
15000 lines ?

Here my theory:

Not exactly to an identical path, right?

What you see are the file records in the database. But the access fails because they are now located at another place.

Solution: Search the docs for how to move the data directory and apply the steps described there.

1 Like

I managed to overlook the docs about that, but when I did do what the documentation said it worked.
But since I’m running on a separate machine, I decided to just stick with the original path.
Don’t know why I decided to change that path.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.