Can't share calenders anymore

Steps to reproduce

  1. go on calender app an share with group, find the group but nothing happens.
  2. public share works in browser
  3. caklender app: deakativated, aktivated, deinstalled, installed same as before
  4. Update from owncloud 10.0.1 to 10.1.0 still the same problem
  5. Update form calender 1.6.1 to 1.6.2 same problem

Expected behaviour

share calender with group or user

Actual behaviour

nothing happens

Server configuration

Operating system : ubuntu 16.04 LTS

Web server: apache2
Server version: Apache/2.4.18 (Ubuntu)
Server built: 2018-06-07T19:43:03

Database: mysql 5.7

PHP version: 7.0

ownCloud version: (10.1.0)

Calendar version: (1.6.2)

List of activated apps:
Enabled:

  • activity: 2.4.2
  • audioplayer: 2.6.0
  • calendar: 1.6.2
  • comments: 0.3.0
  • configreport: 0.1.1
  • contacts: 1.5.5
  • dav: 0.4.0
  • federatedfilesharing: 0.3.1
  • federation: 0.1.0
  • files: 1.5.1
  • files_external: 0.7.1
  • files_pdfviewer: 0.10.0
  • files_sharing: 0.11.0
  • files_texteditor: 2.3.0
  • files_trashbin: 0.9.1
  • files_versions: 1.3.0
  • files_videoplayer: 0.9.8
  • firstrunwizard: 1.1
  • gallery: 16.1.1
  • market: 0.3.0
  • notifications: 0.4.1
  • onlyoffice: 2.1.3
  • ownbackup: 19.1.0
  • provisioning_api: 0.5.0
  • systemtags: 0.3.0
  • templateeditor: 0.4.0
  • updatenotification: 0.2.1
    Disabled:
  • encryption
  • external
  • user_external

ownCloud configuration:
“system”: {
“updatechecker”: false,
“instanceid”: “oc8p4nu9wuyk”,
“passwordsalt”: " REMOVED SENSITIVE VALUE ",
“secret”: " REMOVED SENSITIVE VALUE ",
“trusted_domains”: [
“localhost”,
fkbox.de”,
“192.168.178.2”
],
“datadirectory”: “/var/www/owncloud/data”,
“overwrite.cli.url”: “https://localhost/owncloud”,
“dbtype”: “mysql”,
“version”: “10.1.0.4”,
“dbname”: “owncloud”,
“dbhost”: “localhost”,
“dbtableprefix”: “oc_”,
“dbuser”: " REMOVED SENSITIVE VALUE ",
“dbpassword”: " REMOVED SENSITIVE VALUE ",
“logtimezone”: “UTC”,
“installed”: true,
“maintenance”: false,
“theme”: “”,
“loglevel”: 2,
“mail_from_address”: " REMOVED SENSITIVE VALUE ",
“mail_smtpmode”: “smtp”,
“mail_domain”: " REMOVED SENSITIVE VALUE ",
“mail_smtpsecure”: “ssl”,
“mail_smtpauthtype”: “LOGIN”,
“mail_smtphost”: " REMOVED SENSITIVE VALUE ",
“mail_smtpport”: “465”,
“mail_smtpauth”: 1,
“mail_smtpname”: " REMOVED SENSITIVE VALUE ",
“mail_smtppassword”: " REMOVED SENSITIVE VALUE "
},
“apps”: {
“activity”: {
“enabled”: “yes”,
“installed_version”: “2.4.2”,
“signed”: “true”,
“types”: “filesystem”
},
“audioplayer”: {
“enabled”: “yes”,
“installed_version”: “2.6.0”,
“signed”: “true”,
“types”: “filesystem”
},
“backgroundjob”: {
“lastjob”: “5”
},
“bookmarks”: {
“enabled”: “no”,
“installed_version”: “0.9.0”,
“ocsid”: “168710”,
“types”: “”
},
“calendar”: {
“enabled”: “yes”,
“installed_version”: “1.6.2”,
“signed”: “true”,
“types”: “”
},
“comments”: {
“enabled”: “yes”,
“installed_version”: “0.3.0”,
“types”: “logging”
},
“configreport”: {
“enabled”: “yes”,
“installed_version”: “0.1.1”,
“types”: “filesystem”
},
“contacts”: {
“enabled”: “yes”,
“installed_version”: “1.5.5”,
“signed”: “true”,
“types”: “”
},
“core”: {
“backgroundjobs_mode”: “ajax”,
“enable_external_storage”: “yes”,
“installedat”: “1485904804.2576”,
“lastcron”: “1551538906”,
“lastupdateResult”: “[]”,
“lastupdatedat”: “1551538905”,
“oc.integritycheck.checker”: “[]”,
“public_documents”: “documents/public.php”,
“public_files”: “files_sharing/public.php”,
“public_webdav”: “dav/appinfo/v1/publicwebdav.php”,
“shareapi_allow_group_sharing”: “yes”,
“shareapi_allow_mail_notification”: “yes”,
“shareapi_allow_public_notification”: “yes”,
“shareapi_allow_resharing”: “no”,
“shareapi_allow_social_share”: “no”,
“shareapi_enabled”: “yes”,
“shareapi_enforce_links_password_read_only”: “no”,
“shareapi_enforce_links_password_read_write”: “no”,
“shareapi_enforce_links_password_write_only”: “no”,
“vendor”: “owncloud”
},
“dav”: {
“enabled”: “yes”,
“installed_version”: “0.4.0”,
“types”: “filesystem”
},
“documents”: {
“converter”: “local”,
“enabled”: “no”,
“installed_version”: “0.13.1”,
“ocsid”: “168711”,
“types”: “”
},
“federatedfilesharing”: {
“enabled”: “yes”,
“installed_version”: “0.3.1”,
“types”: “filesystem”
},
“federation”: {
“enabled”: “yes”,
“installed_version”: “0.1.0”,
“types”: “authentication”
},
“files”: {
“cronjob_scan_files”: “500”,
“enabled”: “yes”,
“installed_version”: “1.5.1”,
“types”: “filesystem”
},
“files_antivirus”: {
“av_cmd_options”: “”,
“av_host”: “”,
“av_infected_action”: “only_log”,
“av_max_file_size”: “-1”,
“av_mode”: “executable”,
“av_path”: “/usr/bin/clamscan”,
“av_port”: “0”,
“av_socket”: “/var/run/clamav/clamd.ctl”,
“av_stream_max_length”: “26214400”,
“enabled”: “no”,
“installed_version”: “0.14.0”,
“signed”: “true”,
“types”: “filesystem,dav”
},
“files_external”: {
“allow_user_mounting”: “yes”,
“enabled”: “yes”,
“installed_version”: “0.7.1”,
“ocsid”: “166048”,
“types”: “filesystem”,
“user_mounting_backends”: “dav,owncloud,sftp,dropbox,\OC\Files\Storage\SFTP_Key”
},
“files_pdfviewer”: {
“enabled”: “yes”,
“installed_version”: “0.10.0”,
“ocsid”: “166049”,
“signed”: “true”,
“types”: “”
},
“files_sharing”: {
“enabled”: “yes”,
“installed_version”: “0.11.0”,
“types”: “filesystem”
},
“files_texteditor”: {
“enabled”: “yes”,
“installed_version”: “2.3.0”,
“signed”: “true”,
“types”: “”
},
“files_trashbin”: {
“enabled”: “yes”,
“installed_version”: “0.9.1”,
“types”: “filesystem”
},
“files_versions”: {
“enabled”: “yes”,
“installed_version”: “1.3.0”,
“types”: “filesystem”
},
“files_videoplayer”: {
“enabled”: “yes”,
“installed_version”: “0.9.8”,
“types”: “”
},
“firstrunwizard”: {
“enabled”: “yes”,
“installed_version”: “1.1”,
“ocsid”: “166055”,
“types”: “”
},
“gallery”: {
“enabled”: “yes”,
“installed_version”: “16.1.1”,
“signed”: “true”,
“types”: “”
},
“market”: {
“activity”: “2.4.1”,
“audioplayer”: “2.5.1”,
“calendar”: “1.6.2”,
“contacts”: “1.5.5”,
“enabled”: “yes”,
“files_antivirus”: “0.14.0”,
“files_pdfviewer”: “0.10.0”,
“files_texteditor”: “2.3.0”,
“gallery”: “16.1.1”,
“installed_version”: “0.3.0”,
“market”: “0.3.0”,
“onlyoffice”: “2.1.3”,
“richdocuments”: “2.0.4”,
“signed”: “true”,
“templateeditor”: “0.4.0”,
“types”: “”
},
“notifications”: {
“enabled”: “yes”,
“installed_version”: “0.4.1”,
“types”: “logging”
},
“onlyoffice”: {
“DocumentServerInternalUrl”: “”,
“DocumentServerUrl”: “http://localhost/owncloud/apps/onlyoffice/”,
“StorageUrl”: “”,
“defFormats”: “{“docx”:“true”,“xlsx”:“true”,“pptx”:“true”,“ppsx”:“true”,“txt”:“false”,“csv”:“false”}”,
“enabled”: “yes”,
“installed_version”: “2.1.3”,
“jwt_secret”: “”,
“ocsid”: “174798”,
“sameTab”: “false”,
“settings_error”: “Mixed Active Content\u00a0ist nicht m\u00f6glich. HTTPS-Adresse f\u00fcr Document Server ist erforderlich.”,
“signed”: “true”,
“skey”: “1523712091541”,
“types”: “filesystem”
},
“ownbackup”: {
“enabled”: “yes”,
“installed_version”: “19.1.0”,
“ocsid”: “170674”,
“signed”: “true”,
“types”: “”
},
“ownnote”: {
“enabled”: “no”,
“installed_version”: “1.08”,
“ocsid”: “168512”,
“types”: “”
},
“provisioning_api”: {
“enabled”: “yes”,
“installed_version”: “0.5.0”,
“types”: “prevent_group_restriction”
},
“richdocuments”: {
“enabled”: “no”,
“installed_version”: “2.0.5”,
“ocsid”: “174727”,
“signed”: “true”,
“types”: “prevent_group_restriction”
},
“systemtags”: {
“enabled”: “yes”,
“installed_version”: “0.3.0”,
“types”: “logging”
},
“tasks”: {
“enabled”: “no”,
“installed_version”: “0.9.4”,
“ocsid”: “164356”,
“signed”: “true”,
“types”: “”
},
“templateeditor”: {
“enabled”: “yes”,
“installed_version”: “0.4.0”,
“signed”: “true”,
“types”: “”
},
“updatenotification”: {
“core”: “10.0.10”,
“enabled”: “yes”,
“installed_version”: “0.2.1”,
“ownbackup”: “17.3.0”,
“types”: “”
}

ownCloud log (data/owncloud.log)
{“reqId”:"#####sxhR1",“level”:3,“time”:“2019-02-21T17:35:22+00:00”,“remoteAddr”:“88.94.##.##”,“user”:“Frank_K”,“app”:“OCP\Share”,“method”:“GET”,“url”:"/owncloud/ocs/v1.php/apps/files_sharing/api/v1/sharees?format=json&search=chr&perPage=200&itemType=principals",“message”:“Sharing backend for principals not found”}

share contacts is the same problem!

Did you try this:

  • Export a calendar
  • Create a new test-user
  • Import calendar for test-user
  • Test sharing this calendar

Currently I’m out of better ideas. Sorry.

Hey,

could it be possible that you have disabled the “Share Files” app or have disabled the following setting in your “Sharing” tab in the admin backend?

Allow apps to use the Share API

Obviously he can share files, so sharing must be on.

Hey,

ah yes i’ve missed this because its hidden in the text because fully output of the activated apps was committed :confused:

So probably only the second suggestion about the setting needs to be checked.

1 Like

The problem is not that easy to solve. See owncloud.log sharing backend is missing!

General error: 1364 Field ‘publicuri’ doesn’t have a default value!

Can anybody tell me what ‘default value’ I can put in field ‘publicuri’?

Hey,

i did the following search: https://github.com/owncloud/core/search?q="publicuri"&unscoped_q="publicuri" and found this code:

If i’m understanding this correctly this should have been already executed during a former upgrade of ownCloud but maybe you can find the required information you are looking for in there?

I don’t understand that php code, and where can I implement it? I added the column publicuri, because it wasn’t there and I had sync problems on all systems. After adding publicuri syncing was working, but in later upgrades I can’t share calenders with other users anymore. So I think I have to fix that in mysql database. And what command will fix it?

Hey,

unfortunately i also don’t understand this PHP code. :confused:

But i think this is a quite good example why it is not recommended to do own database modifications, it seems the “correct” fix by ownCloud wasn’t applied due to this.

To solve your problem maybe you can setup a fresh ownCloud 10.3.1 test installation and then compare the newly created database with your current one to see if there are any additional differences. Then i think you can easily update the current database to make this to work again.

1 Like

The Problem still exists. Any help?
I checked the updates/upgrades for the calendar app and I have all available.
But I still can’t share calenders to other users.
Public share is possible.