Can't share editable document



Hello. I'm trying to share a document from the Document application, so I can send the link to other people and we can all edit the document online. I can share a document that other can download, but I can't share it in edition mode.

Here is the description of the problem.

Steps to reproduce
1. Go to the Document application
2. Open a document listed
3. Activate the 'Share link' button

Expected behaviour
It should provide me a shareable link

Actual behaviour
The button remain in "thinking" mode, as shown here:

Server configuration
Operating system: Debian Stretch
Web server: Nginx
Database: Mariadb
PHP version: PHP 7
ownCloud version: 9.1.2
Updated from an older ownCloud or fresh install: Fresh install
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption): No

Integrity status for oC9+

No errors have been found.


Please check you owncloud logfiles if there is an error. Also disable add-blockers and other plugins that can block connections (anti-virus).


When I make an attempt to share the file, I get nothing in /var/www/owncloud/data/owncloud.log related to that action.


Browser extensions and browser error console?


I use Chromium with no extension, and here are the console error messages I found:


After testing different things, I have some updates.

If I use firefox instead of chromium, I immediately receive an error message box saying "Error while sharing. Error" when I try to tick the share box, while with chromium, it simply stayed in "think" mode.

The sharing feature works well from the file manager. So I can share a public link to file, so people can download the file.
The problem only occurs when I try to share a file in collaborative mode, from within the Documents application.

I checked all the logs I could find, from nginx, php, owncloud, but I see no error message anywhere. I'm lost...


@cyphix As written in IRC this might be also just a bug in the documents app so please report it to the app developer at: