Can't sync files > 50MB

Expected behaviour

Files greater than 50MB should sync

Actual behaviour

I suspect the problem is not with Owncloud but that my provider has changed something.
Please can you tell me what question I should ask?
Thanks

Sync fails with error message as follows:
24/05/2021 15:54:22, eBay/comic books/List of Comic Books.odg, C:\Rich2,Server replied “500 Internal Server Error” to “PUT https://REDACTED.com/owncloud/remote.php/dav/uploads/richard/4013101048/0000000030000000” (An exception occurred while executing ‘SELECT fileid, storage, path, parent, name, mimetype, mimepart, size, mtime,
storage_mtime, encrypted, etag, permissions, checksum
FROM oc_filecache WHERE storage = ? AND path_hash = ?’ with params [3, “ac48476f19ecf330d24aff0f756d83d1”]:

SQLSTATE[HY000]: General error: 2006 MySQL server has gone away)

Steps to reproduce

  1. Put a file of size > 50MB in a synced folder
  2. Watch the error happen

Server configuration

Operating system:

Web server: cPanel Shared Linux host

Database:MySQL 5.7.34-cll-lve

PHP version: 7.4.16

ownCloud version:

Storage backend (external storage):

Client configuration

Client version: 2.7.5

Operating system: Win10

OS language:

Qt version used by client package (Linux only, see also Settings dialog):

Client package (From ownCloud or distro) (Linux only):

Installation path of client:

Logs

Please use Gist (https://gist.github.com/) or a similar code paster for longer
logs.

Template for output < 10 lines

  1. Client logfile: Output of owncloud --logwindow or owncloud --logfile log.txt
    This is the log that came from clicking “Log settings” in the Settings tab of the client
    Owncloud client log file

  2. Web server error log:

  3. Server logfile: ownCloud log (data/owncloud.log): 10.7.0

Perhaps log into the machine, connect to the mysql server and run the select. Not sure what cPanel does that the mysql server is inaccessible for your website (ownCloud) but that should never happen. So perhaps just ask the support team why that is happening.

I called the host’s tech support and a firewall rule (he said “URL encoding error”) was blocking it. He didn’t know why it was doing that but, when he whitelisted it, the file uploaded. Thanks for your help, Erik.