Can't upload files bigger than 1MB with Android App

android
10

#1

On my Xperia Z5 Compact on android nougat I can't upload any file larger than 1MB. Anything below that works, anything above that fails with a "no network available" error.

Any idea where should I look at to solve this issue?


#2

Does it work from a desktop sync client?

If yes, the problem is with the app, if not it's a server configuration issue.


#3

It does work from a desktop sync client both on mac and windows (my partner has windows). But what could be the problem with the app?


#4

I mean, desktop client is sync and this is uploading... I don't know if there might be a difference serverwise


#5

Okay, this is what you can try:

disable the anti virus app in your ownCloud server if you have one.

Try this configuration: 9.1.0, Android client 2.1.1


#6

Is this why I haven't managed to make the androidapp auto-upload camera pics??

I've had this problem for a year at least. Same thing with both the OC android app as well as with the fork called Cirrus.

I'll do some testing and get back on here.

Thanks for the heads-up!

Edit:
Ok, this was an ambigous test that raises more questions than it answers.
I changed the resolutions of the stock android camera, from lowest to highest.

0.9 > 2.1 > 3.1 > 5.0 > 9.7 > 13 Mpx.
205 kB, 404 kB, 632 kB, 1005 kB, 1791 kB and 2462 kB.

The desktop sync client barfed on the last three, but the android client did upload all of the six pics with no problem.
The last three pics the desktop sync client eventually managed to download properly after a few minutes of timeouting.


#7

I have owncloud 10. I can't go back. Android Client, not too sure if I can revert either...


#8

I have same issue :frowning:


#9

Many things change in 12 months.

Would be great to know your specific setup and configuration.


#10

Android app version 2.9.3, owncloud server 10.0.10.4 running on Ubuntu + Nginx + php-fpm 7.0.32. It used to work 2 months ago and I’m able to upload files smaller than 1MB. Here is part of error log:
{“reqId”:“090de6d6-966b-443f-a8e7-73e198282c96”,“level”:0,“time”:“2019-01-10T16:22:24+00:00”,“remoteAddr”:“94.230.153.108”,“user”:“ondra”,“app”:“OC\Authentication\Token\DefaultTokenProvider::updateToken”,“method”:“PROPFIND”,“url”:"/remote.php/dav/files/ondra/temp/",“message”:“updating token 93, last check is now 1547136292”}
{“reqId”:“090de6d6-966b-443f-a8e7-73e198282c96”,“level”:0,“time”:“2019-01-10T16:22:24+00:00”,“remoteAddr”:“94.230.153.108”,“user”:“ondra”,“app”:“OC\Authentication\Token\DefaultTokenProvider::getToken”,“method”:“PROPFIND”,“url”:"/remote.php/dav/files/ondra/temp/",“message”:“token 72120c3fc2cd02122fc448d072423246ffca7c10671b19c51c39d1a035b995f545cf0c0a76e3e02f117f64cadef49df39536a7e674c715adc544405742b42c4d does not exist”}
{“reqId”:“041c344c-c2fe-468d-9562-3380e4ceb862”,“level”:0,“time”:“2019-01-10T16:22:24+00:00”,“remoteAddr”:“94.230.153.108”,“user”:“ondra”,“app”:“OC\Authentication\Token\DefaultTokenProvider::updateToken”,“method”:“PROPFIND”,“url”:"/remote.php/dav/files/ondra/temp/20190109_121833.jpg",“message”:“updating token 93, last check is now 1547136292”}
{“reqId”:“041c344c-c2fe-468d-9562-3380e4ceb862”,“level”:0,“time”:“2019-01-10T16:22:24+00:00”,“remoteAddr”:“94.230.153.108”,“user”:“ondra”,“app”:“OC\Authentication\Token\DefaultTokenProvider::getToken”,“method”:“PROPFIND”,“url”:"/remote.php/dav/files/ondra/temp/20190109_121833.jpg",“message”:“token 72120c3fc2cd02122fc448d072423246ffca7c10671b19c51c39d1a035b995f545cf0c0a76e3e02f117f64cadef49df39536a7e674c715adc544405742b42c4d does not exist”}
{“reqId”:“041c344c-c2fe-468d-9562-3380e4ceb862”,“level”:0,“time”:“2019-01-10T16:22:24+00:00”,“remoteAddr”:“94.230.153.108”,“user”:“ondra”,“app”:“webdav”,“method”:“PROPFIND”,“url”:"/remote.php/dav/files/ondra/temp/20190109_121833.jpg",“message”:“Exception: HTTP/1.1 404 File with name temp/20190109_121833.jpg could not be located: {“Exception”:“Sabre\\DAV\\Exception\\NotFound”,“Message”:“File with name temp\/20190109_121833.jpg could not be located”,“Code”:0,“Trace”:”#0 \<path to owncloud instalation>\/owncloud9-1\/apps\/dav\/lib\/Tree.php(67): OCA\\DAV\\Connector\\Sabre\\ObjectTree->getNodeForPath(‘temp\/20190109_1…’)\n#1 \<path to owncloud instalation>\/owncloud9-1\/lib\/composer\/sabre\/dav\/lib\/DAV\/Server.php(966): OCA\\DAV\\Tree->getNodeForPath(‘files\/ondra\/tem…’)\n#2 \<path to owncloud instalation>\/owncloud9-1\/lib\/composer\/sabre\/dav\/lib\/DAV\/Server.php(1665): Sabre\\DAV\\Server->getPropertiesIteratorForPath(‘files\/ondra\/tem…’, Array, 0)\n#3 \<path to owncloud instalation>\/owncloud9-1\/lib\/composer\/sabre\/dav\/lib\/DAV\/CorePlugin.php(355): Sabre\\DAV\\Server->generateMultiStatus(Object(Generator), false)\n#4 [internal function]: Sabre\\DAV\\CorePlugin->httpPropFind(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#5 \<path to owncloud instalation>\/owncloud9-1\/lib\/composer\/sabre\/event\/lib\/EventEmitterTrait.php(105): call_user_func_array(Array, Array)\n#6 \<path to owncloud instalation>\/owncloud9-1\/lib\/composer\/sabre\/dav\/lib\/DAV\/Server.php(479): Sabre\\Event\\EventEmitter->emit(‘method:PROPFIND’, Array)\n#7 \<path to owncloud instalation>\/owncloud9-1\/lib\/composer\/sabre\/dav\/lib\/DAV\/Server.php(254): Sabre\\DAV\\Server->invokeMethod(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#8 \<path to owncloud instalation>\/owncloud9-1\/apps\/dav\/lib\/Server.php(298): Sabre\\DAV\\Server->exec()\n#9 \<path to owncloud instalation>\/owncloud9-1\/apps\/dav\/appinfo\/v2\/remote.php(31): OCA\\DAV\\Server->exec()\n#10 \<path to owncloud instalation>\/owncloud9-1\/remote.php(165): require_once(’\/var\/www\/ownclo…’)\n#11 {main}",“File”:"\<path to owncloud instalation>\/owncloud9-1\/apps\/dav\/lib\/Connector\/Sabre\/ObjectTree.php",“Line”:193}"}


#11

Hey,

maybe some too low web server configuration options like the mentioned below is causing your issue?

Some additional configuration options to enable to upload larger files seems to be mentioned in:

https://doc.owncloud.org/server/administration_manual/configuration/files/big_file_upload_configuration.html


#12

I’ve checked all of them - request body is set to 8M (the file I want to upload is 1.5M only)


#13

Hey,

maybe there are even more currently not known / documented web server configuration settings causing this issue?


#14

No idea where to look for them. I’ve checked nginx, php configuration. There is no clue in nginx and php logs. The only clue is owncloud log I’ve posted but I can’t make anything out of it. And it used to work. But I can’t say for sure what happend - I don’t use uploading files over 1M very often so it could happen month or 2 ago. The other clue is taht it works from desktop sync - so I guess problem is in the android app not server configuration.