Can't upload large files greater than 8MB

webserver_issue

#1

Steps to reproduce

  1. Upload large file larger than 8MB via browser
  2. After upload it stay “Processing file”
  3. Trying to use local desktop app on Mac generates a “403 Forbidden” to "MOVE

Expected behaviour

Tell us what should happen
Either should load fine
Smaller files work fine from either browser or desktop sync

Actual behaviour

Tell us what happens instead
On desktop sync “403 Forbidden” to "MOVE…
In browser file uploads then it stays on “Processing file” forever

Server configuration

Operating system:

  • CENTOS 7.6 virtuozzo [vps] [ v78.0.11 ]
    iMac app 2.5.3 (build 11290)

Web server:

Database:

**PHP version:**7.2

ownCloud version: (see ownCloud admin page)

Updated from an older ownCloud or fresh install:

Where did you install ownCloud from:
Softaculous Cpanel

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

No errors have been found.

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

or 

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/…

Are you using encryption: yes/no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…

LDAP configuration (delete this part if not used)

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';


Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration

Browser:

Operating system:

Logs

Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

#2

Hey,

maybe the omitted ownCloud version or Web server error / ownCloud log could give some hints why this is happening?


#3

Appologies Tom. Where do I find the log?
Softaculous loads version 10.1.0
I have tried downloading latest version and starting from scratch using OwnCloud install steps.
Thanks.
Nagui


#4

Hey,

the web server error log is probably something which you need to find on your own as this looks to me something which depends on your environment.

For the ownCloud part it seems the omitted part of the template gives some hints where to look at:


#5

Thanks again Tom.
Log file is empty. See attached.

I also took a couple of snapshots of the errors.


#6

Hey,

on your posted screenshot i can see a “Forbidden to MOVE” message reported by your web server. Based on this message i did the following search:

https://central.owncloud.org/search?q=%22forbidden%22%20%22move%22%20order%3Alatest

and found the resources below:

Are you also getting the “is out of base uri” message discussed there?

If not it could be possible that your web server is preventing (Forbidden to MOVE) ownCloud from working correctly.


#7

Tom,
No the URL is correct
here is the error in full
2019-02-24 12:20:33 PM, Test folder/Leadership BI.pdf, ownCloud,Server replied “403 Forbidden” to “MOVE https://behavior-intelligence.com/owncloud/remote.php/dav/uploads/naguibihelek/2776656224/.file” (skipped due to earlier error, trying again in 10 second(s))

Where could this be on the server that is preventing that. I have tried tech support several time, but because this is 3rd party app, they check all setting for timeout and filesizes and everything looks fine.

Smaller files are fine. I can upload, and I can use desktop app to sync. So unlikely that server is preventing that - no?

Lastly, is there a way that I can load from cpanel -> file manager and have it show up in files/folders of the app properly?

Thanks in advance.
Nagui


#8

Hey,

from what i know / have read in the past ownCloud is using various extended / advanced HTTP Methods (MOVE is one of them) which needs to be available / allowed by the web server operating ownCloud.

Such methods might be blocked / restricted with hosted / cpanel installations. Maybe you could ask tech support which HTTP Methods are currently allowed and if MOVE is one of the allowed ones?