Cant't port forward owncloud to port 443 only DMZ works

I’am running version 10.7.0

Steps to reproduce

1.I have tried to port port forward to port 443 - It won’t work
2.I have tried to write the static IP address in different pages for instance: …owncloud.conf, php, port page …It wont work
3. when I set up the router to access owncloud through DMZ everything works - but I believe its not secure to do it like that

Expected behaviour

Tell us what should happen

I want to access owncloud through port 443

Actual behaviour

Tell us what happens instead

nothing - its not possible to reach owncloud here.

Server configuration

Operating system:
ubuntu 20.04

Web server:

apache2

Database:
MariaDB

PHP version:
7.2 php

ownCloud version: (see ownCloud admin page)
10.7

Updated from an older ownCloud or fresh install:

fresh

Where did you install ownCloud from:

Signing status (ownCloud 9.0 and above):

“It wont work” is never a useful description of a problem. How could someone help without knowing more details?

And BTW, port forwarding/router config is not an ownCloud issue, surely off-topic.

Hi again
I have read many issues about owncloud can’t port forward and spend time on the issue. I have other servers that works as expected. So it would be great to come with some solutions…
Best regards
Christian

Well, 443 is the standard port for https. So, none of the supplied documentations for connecting with https works for you? And as I said, it’s more about configuring the Apache server than ownCloud itself.