CentOS 7 upgrade to owncloud 10 - not found?

centos
upgrade
10

#1
[root@nas ~]# yum update

Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: centos.mia.host-engine.com
* epel: download-ib01.fedoraproject.org
* extras: pubmirrors.dal.corespace.com
* updates: mirror.tzulo.com
Resolving Dependencies
--> Running transaction check
---> Package owncloud.noarch 0:9.1.5-1.1 will be obsoleted
---> Package owncloud-deps-php5.noarch 0:9.1.5-1.1 will be updated
---> Package owncloud-deps-php5.noarch 0:10.0.0-1.1 will be an update
---> Package owncloud-files.noarch 0:9.1.5-1.1 will be updated
---> Package owncloud-files.noarch 0:10.0.0-1.1 will be obsoleting
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================================================================================================================================================
Package Arch Version Repository Size
===================================================================================================================================================================================================================
Installing:
owncloud-files noarch 10.0.0-1.1 ce_stable 30 M
replacing owncloud.noarch 9.1.5-1.1
Updating:
owncloud-deps-php5 noarch 10.0.0-1.1 ce_stable 5.9 k

Transaction Summary

Install 1 Package
Upgrade 1 Package

Total download size: 30 M
Is this ok [y/d/N]: y
Downloading packages:
Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
owncloud-files-10.0.0-1.1.noar FAILED
http://download.owncloud.org/download/repositories/stable/CentOS_7/noarch/owncloud-files-10.0.0-1.1.noarch.rpm: >
[Errno 14] HTTP Error 404 - Not Found ] 0.0 B/s | 0 B --:--:-- ETA

So, what's the issue? Is owncloud 10 really released for CentOS 7?


Download repository package missing
#2

Upgrading to 10 is not recommended yet for production systems, so the stable packages yet direct to 9.1.5, until we release 10.0.1 in a few weeks. You can use the 10.0.0 packages directly, though, via this link: https://download.owncloud.org/download/repositories/10.0/owncloud/


#3

Hmm then I'm wondering why i got the upgrade notification during yum update. I am using the ce.stable repo.


#4

I have the same issue with Ubuntu 16.04 LTS.

http://download.owncloud.org/download/repositories/stable/Ubuntu_16.04  owncloud 10.0.0-1.1

404 Not Found

I'm unsure why it tries to download Version 10 from the stable repo. As I remember I never changed the configuration of release channels, so why does it try to get this version?

P.S.: I dont want to upgrade, but apt provides this version.


#5

i got the same issue on ubuntu 16.04 have you guys done someting to the repo so it says that an update is avalible?


#6

I'm having the same issue on the Raspberry Pi version of Ubuntu 16.04 LTS. It must be something screwie going on with the Owncloud update repos.

My biggest concern is that I can't seem to update anything else on my server whilst having this problem with the owncloud repo. I have python, systemd, udev, and several other updates available, and none of them will happen while I'm getting this error from owncloud.


#7

if you got webmin then you can skip it by unchecking it.

or

apt

Hold a package:

sudo apt-mark hold package_name

Remove the hold:

sudo apt-mark unhold package_name

so in this case its sudo apt-mark hold owncloud-deps-php7.0 <- change it to what php you got
sudo apt-mark hold owncloud-files

after update is done dont forget to do the unhold command


#8

I just did an
apt install --only-upgrade everything besides owncloud

I just chained together all of the other packages that were available for upgrade and that seemed to work.


#9

If this is a productive environment please wait for the release of 10.0.1 or 10.0.2 before doing any upgrades as advised in [1]. Until that time they probably have fixed the repositories. You can also switch to the 9.1 repositories [2] which still gives you updates for your current 9.1.x

Disclaimer: for production systems we recommend to wait for the first update release. it is to be expected in about 4 weeks.

[1] https://owncloud.org/blog/introducing-owncloud-x/

[2] https://download.owncloud.org/download/repositories/9.1/owncloud/


#10

Nice to know that we should wait ... it was in the stable repo for centos7 so a normal yum update upgraded it, and then I needed php56, which is not in the normal centos repo.

Problems is solved now, but it seams it should not be in the stable repo yet.


#11

Yes, most people came to the same conclusion. A first version of a major release was never pushed directly to the "stable" repository in the past so this was probably a mistake (The 10.0.0 release was rolled back from that repo a few hours later).


#12

I had this crazy thing happening, I have 2 owncloud servers. I did an update it one, and successfully upgraded to 10.0.0, days latter I tried to do the upgrade on the other server and there was no new releases... I came back to the first server checked the version at the repository, and was the 9.1.6.

I read that they pushed the 10 to the repositories by mistake and they took it out. I'm not in a rush to upgrade. But I'm sort of scared that they are thinking about making owncloud under pay license. That will be bummer since I love the project, and I use it for my personal stuff. I participate on the translation to Spanish like a lot. I'll just keep waiting until the 10.0.1 or .2 stable is at the repository (hopefully)


#13

From what i know ownCloud X/10 is available at

https://download.owncloud.org/download/repositories/10.0/owncloud/

since the release but just not at the "stable" repository at:

https://download.owncloud.org/download/repositories/stable/owncloud/

So no need to worry about stuff like pay license or similar :slight_smile:


#14

Hey Tom42, thanks for the reply.

I'm afraid to inform you that the version 10 is not available at the repository (as they inform on the link you provided :slight_smile: :smiley:


#15

I'm afraid to inform you that the version 10 is available at the repository from the link i have provided :slight_smile::grinning:


#16

I'm afraid to inform that I'm doing something wrong... I will check.

Thanks for the patience


#17

Maybe the apt-cache is broken? I would try to remove the repository from the apt config, run apt-get update, re-add the repositories again and then run apt-get update once more.


#18

Since 10.0.2 is released yet, did something changed from the status "do not use Owncloud X in production environment"?

In Yum ce_stable 9.1.6 is still the last stable version..