Certificate installation issues

ssl
9.1.x

#1

I am in a bad loop in trying to install a GoDaddy Cert in owncloud. Put my 3 certs in folder. Went to install and got.
error 20 at 0 depth lookup:unable to get local issuer certificate │
│ Issues found while verifying the certificate chain: │
│ /var/lib/owncloud/admin/files/SSLCerts/certificate.pem: OU = Domain

To resolve this I had to combine the cert with itermediates . Ran openssl verify now on new certificate.pem and got the ok.

So tried again . This time the private_key does not match. So after running

openssl rsa -noout -modulus -in private_key.pem | openssl md5
and

openssl rsa -noout -modulus -in certificate.pem| openssl md5

this is true. They don't match. But if I run it against the original certificate.pem(before combining) they do.

So how do I get by this. If fix one it breaks the other.


#2

Hi,

ownCloud doesn't handle any certificates (except the ones for outgoing connections to external systems). In general its a job of your webserver.

How to configure such certificates are also not ownCloud specific so i would suggest to do some more research on the net outside of the scope of ownCloud. OpenSSL e.g. has some support resources listed at their webpage at [1]. If the initial message is showing up at your webservers logfiles a support forum dedicated to your webserver might be another possibility.

[1] https://www.openssl.org/support/


#3

I have done research. How I got as far as I did.

Owncloud doesn't seem to handle a lot of things it is supposedly capable of doing. Certificates, Active Directory, etc. Running this on Owncloud Appliance. Not sure how anything on appliance is not supported but will keep looking.

Thanks


#4

Quite good tutorials are the ones from digitalocean.com which might help here. The following is e.g. for Godaddy certificates on apache/nginx: