Change default Ports for Owncloud on newest appliance


#1

I have having an issue changing to default ports for owncloud from 443 and 80.
I have tried to change the univention/templates/files/etc/apache2/sutes-available/ssl.d/00start and univention/templates/files/etc/apache2/sutes-available/000-default.d/00start
I changed the ports to be 4433 and 8080, then restarted apache2 service
When I did that the ports I changed did not work and the server still responded on the 443 and 80.

I must be missing something.
If someone knows how to change the ports can you please let me know. I already have port forwarding setup to go to other items in the firewall so need this to listen on other ports


#2

this could be interesting for you


#3

It is generally not advised to change the UCS default webserver ports. UCS expects that the webserver is listening on the default ports, so things may break in the future if you change these defaults.

I would suggest to put a reverse proxy in front of your UCS server and redirect to your UCS server depending on your requirements.


#4

I am going to try and do a port forward redirect from my firewall and see if that works.
If I can keep the settings the way they are and just apply firewall rules, that maybe the easiest route?