Change UPLOAD File Size

doc_answered
upload_limit

#1

I am trying to increase the Max Upload Size from 2MB

I have read this:
https://wiki.bitnami.com/Applications/BitNami_ownCloud#How_to_increase_the_allowed_size_of_the_uploaded_files.3f

How to increase the allowed size of the uploaded files?

ownCloud configures the max upload size in the installdir/apps/owncloud/conf/htaccess.conf file. By default is configured to 512M.
...
<IfModule modphp5.c>_
phpvalue upload_max_filesize 513M_
phpvalue post_max_size 513M_
phpvalue memory_limit 512M_
...
You can change these options to increase the size. Please, specify the size using "M" (i.e. 1000M) and not "G" (i.e. 1G). There is known issues with 2048M but 2000M is working fine.
Remind to restart the Apache server after this change and also replace INSTALLDIR with your installation directory.

BUT I am on ownCLOUD v9.latest on Mac OSX Server El Capitan .latest and I do not see the directory or file: installdir/apps/owncloud/conf/htaccess.conf


#2

Hi,

please see the documentation available here on how to raise the upload limits:

https://doc.owncloud.org/server/9.1/admin_manual/configuration_files/big_file_upload_configuration.html

However if you're running bitnami its recommended to ask such questions at their support channels. If not then you should ask this at a support channel for Mac OS X Server. Bot platforms are not that widely spread here at the forums and people at the mentioned channels are better able to help you.

Furthermore you should note that running ownCloud on Mac OS X Server is not supported.


#3

Thank you Real Rancor :slight_smile:

I did try that link and method.

I edited the .htaccess file on Mac OSX Server by copying the file out, editing it, replacing the file, resetting permissions, and rebooting ... but I got an error saying my config was wrong:

I had this in my htaccess file: [screenshot link below]
https://dl.dropboxusercontent.com/u/5485939/OWNCLOUD/Remote%20Desktop%20Picture%2028%20July%202016%20at%2012.41.46%20BST.png


#4

You can also try your php.ini file. Perhaps changing this value via .htaccess is not allowed/enabled. Just create a test.php in your Document-Root with the content:
<?php phpinfo(); ?>
And open in your browser. It should show you the path to your php.ini.


#5

Thanks tflidd

I did that and set upload to 100M

Now in ownCloud it has gone up from 2Mb to 8MB ?!


#6

Please see:

The upload_max_filesize isn't the only setting you need to raise and it seems you havn't read the documentation linked there completely as you only tried to raise that one.

Overall everything is explained at the documentation so please follow it carefully to raise the upload limit.

Edit

The post_max_size defaults to 8M according to:

https://secure.php.net/manual/en/ini.core.php#ini.post-max-size

so the new limit of 8MB is caused by that setting.


#7

I did the following, and it worked on 2 QNAP systems:

G
ChB