Change URL for owncloud

Hi,
Hope this finds you well.
I am trying to follow this link to change the URL of my Owncloud server so that when people type in “owncloud.mydomain.com” it goes to my owncloud app instead of the univention portal. Here is what I did

  1. univention-app shell owncloud (to enter the owncloud docker)
  2. cd /etc/apache2/sites-enabled/
  3. I could not find the owncloud.config but only default.config, so i added Alias / “/var/www/owncloud/” to default.config file
  4. cd /var/www/owncloud/config/config.php
  5. edit ‘overwrite.cli.url’ => ‘h t t p://localhost/’ (I can only have 1 URL in my post lol )

After that, I restarted the whole server because I don’t know how to restart the Apache server only. However, it still did not open owncloud directly when I type in the URL. Then I went to check the files that I changed, I found that the default.config did not save the change that I made. My change on config.php was saved though. I am using VMware appliance and the owncloud version is: 10.6.0. Any help is appreciated. Thank you very much!

First, there really should be a owncloud.conf, not owncloud.config, at /etc/apache2/sites-enabled/. Look it up again :slight_smile:
Second, to restart Apache use sudo service apache2 restart.
Hope it helps

@isantana I do not think this is a good advice. The appliance uses ownCloud in a docker, where there is no owncloud.conf, see base/50-apache.sh at master · owncloud-docker/base · GitHub

@JCXfeng I am not familiar with the appliance, but I found this App Settings :: ownCloud Documentation - scroll to the end of the page and look at the univention ownCloud App Settings

I’m not sure if this is sufficient, maybe @dmitry can tell more?

2 Likes

Thanks for pinging me @cortho

Here is the info required:

https://doc.owncloud.com/server/admin_manual/appliance/configuration/login_information.html

here is the important part as a picture:

Here is what you need to execute on the host:

ucr set apache2/startsite=/owncloud
service apache2 restart
2 Likes

@dmitry Thank you for the info!
After I started the owncloud docker shell, I tried

ucr set apache2/startsite=/owncloud

But it says,

bash: ucr: command not found

Am I missing something?

1 Like

Yes. The word host.

ucr is an univention intern script, that’s why it’s not available inside our ownCloud docker container.

1 Like

Sorry. What do you mean I am missing the word “host”? Do you mean I should execute

ucr set apache2/startsite=/owncloud
service apache2 restart

outside of the docker shell?

1 Like

That’s what I wrote originally, yes :slight_smile:

Right after you login on the command line in to your appliance you are on the host system of the appliance, the univention part. When you execute the univention-app shell owncloud you get inside the docker container, this is the ownCloud part.

Univention commands won’t work inside ownCloud’s docker container, hence the error message.
ucr is an univention script, and only available on the host system.

1 Like

Sorry for the late reply. It worked!
Thank you very much for the instruction. You are awesome my friend!

2 Likes