Change user passwords responds with a "Bad Signature"

Steps to reproduce

  1. log in as admin
  2. change to user administration
  3. select desired user
  4. click on pencil for changing password
  5. type new password
  6. press enter

Expected behaviour

a new password is set

Actual behaviour

The password is not set. The user can still login with the old password. The XHR Request shows an “Bad Signature” as response.

Server configuration

Operating system: Ubuntu 16.04.6

Web server: Apache

Database: MySQL

PHP version: 7.2.21

ownCloud version:

Updated from an older ownCloud or fresh install: updated

Where did you install ownCloud from:

Signing status (ownCloud 9.0 and above): No errors have been found.

The content of config/config.php:

List of activated apps:

  - configreport: 0.2.0
  - dav: 0.4.0
  - encryption: 1.3.1
  - federatedfilesharing: 0.4.0
  - files: 1.5.2
  - files_external: 0.7.1
  - provisioning_api: 0.5.0
  - comments
  - external
  - federation
  - files_sharing
  - files_trashbin
  - files_versions
  - files_videoplayer
  - firstrunwizard
  - market
  - notifications
  - systemtags
  - updatenotification
  - user_external

Are you using external storage, if yes which one: no

Are you using encryption: yes

Are you using an external user-backend, if yes which one: no

Client configuration

Browser: Chrome 76.0.3809.100

Operating system: Win 10


Browser log:


it looks to me that this:

doesn’t match to the following from your pasted config.php:

    "ownCloud version": "",

Maybe you could update to the latest 10.2.1 version first and try again afterwards?

Hi Tom,

While I was writing this post, I just made the update from version to
so the problem exists in both versions.


maybe this asked but omitted information within the partly filled out template could give you some pointers about your issue?

#### Web server error log
Insert your webserver log here

#### ownCloud log (data/owncloud.log)
Insert your ownCloud log here

I have also seen the following in the pasted config.php:

"server SAPI": "cgi-fcgi",

I’m not sure if this is relevant but from what i have read in the past ownCloud only supports Apache with mod_php officially:

and lists nginx with php-fpm as an alternative but unsupported option:

Personally i’m using the alternative option with nginx and php-fpm and haven’t found any issues with that setup yet.