Chinese filenames blocking sync

help

#1

I am facing issues with files that have names in traditional and simplified Chinese.
I did some searches online but I could find that much so I thought it may be easier to post here and see if anyone can help.
Basically with mac and pc client the synchronisation stuck at every file with Chinese name. I also experienced that with a .rar with the connection get cut. Of course, changing file names to normal english characters everything works but the point is that I need to be able to manage file named in Chinese.

Thank you in advance.

Michael


#2

I assume you have already tried running the sync client with other locale settings (zh-CN)

Unfortunately no better idea so far.


#3

Can you provide an example file and steps to reproduce?

Did you try it with demo.owncloud.org ?

In that - connecting the client to demo.owncloud.org and trying to sync the files there


#4

Can you tell me how to do it,I could not find the config file of the client anywhere (I am using Mac)


#5

I do not get error message, but I cannot see the file in the demo folder.


#6

is it this?


#7

I don’t know about mac, but isn’t mac-os based on linux?

Usually I start the trouble making app via shell-script, prefixed with the locale settings.

You might have to install the locate first. Then you could try something like

#!/bin/bash
export LANG=zh-CN.UTF8
exec <whatever>

Maybe UTF8 isn’t a good selection. Instead of LANG, you could also try LC_ALL.


#8

Yes, the problem is locare the file in MAC, online I found wrong info about its location


#9

I could not mange to make it work!!!


#10

Confirmed, in the demo it works.
I am thinking if the problem may be in the setting of my ownCloud installation, maybe in the language settings? Possible?

Thanks,

Michael


#11

Does the .rar filename have chinese (or other non-English) characters too?

Are you running ownCloud on a shared hoster instead of a vserver/VM/server?

The ‘connection closed’ in unicode reminds me of https://github.com/owncloud/client/issues/6516

Did you create your MySQL DB with 4 byte characters? https://doc.owncloud.org/server/10.0/admin_manual/configuration/database/linux_database_configuration.html#configure-mysql-for-4-byte-unicode-support


#12

Hi guruz,
Yes, the .rar file has Chinese characters and now (I rebooted) I am getting “connection closed” per all the files with Chinese character in the name.

I am running ownCloud locally on a RaspberryPI3:

Server: Localhost via UNIX socket
Server type: MariaDB
Server version: 10.1.23-MariaDB-9+deb9u1 - Raspbian 9.0
Protocol version: 10
User: XXXXX
Server charset: UTF-8 Unicode (utf8)

Apache/2.4.25 (Raspbian)
Database client version: libmysql - mysqlnd 5.0.12-dev - 20150407
PHP extension: mysqliDocumentation curlDocumentation mbstringDocumentation
PHP version: 7.0.30-0+deb9u1


#13

So that’s not the utf8mb4 character set, utf8mb4_bin collation mentioned in https://doc.owncloud.org/server/10.0/admin_manual/configuration/database/linux_database_configuration.html#configure-mysql-for-4-byte-unicode-support ?


#14

Sorry cannot really follow you, can you help me a bit more.
Thanks;)


#15

I did some changed and this is what I get if:
mysqladmin -u owncloud -p var | grep -E ‘character|collation’ | tr -s ’ ’

| character_set_client | utf8mb4 |
| character_set_connection | utf8mb4 |
| character_set_database | utf8mb4 |
| character_set_filesystem | binary |
| character_set_results | utf8mb4 |
| character_set_server | utf8mb4 |
| character_set_system | utf8 |
| character_sets_dir | /usr/share/mysql/charsets/ |
| collation_connection | utf8mb4_unicode_ci |
| collation_database | utf8mb4_unicode_ci |
| collation_server | utf8mb4_unicode_ci |

I the only thing I have been unable to change is “character_set_system” and I have no idea of to make it since whenever I try adding

[mysqld]
character_set_server=utf8mb4

the result restarting the db server is always:
mysqladmin: unknown variable ‘character-set-server=utf8mb4’

Let me know if anyone can help, I am running mad on this;)))
Cheers,

Michael