Clamscan antivirus error after OC update


#1

Dear all,

I am running ownCloud 10.0.9 services on a shared webhosting server. I do not have access on the command line interface.

I have migrated my previous versions of OwnCloud to the 10.0.0.9 and now I am unable to upload any files.

I got the following error message:
Either the ownCloud antivirus app is misconfigured or the external antivirus service is not accessible. Error starting process "/usr/bin/clamscan - 2>&1

I didn’t change the configuration of the antivirus.

The webhost provider didn’t change the antivirus settings on the server.

Thank you in advance for your help.

I can access to antivirus settings panel
image


#2

Hi,

Can you check the antivirus settings on your web interface?


#3

Yes

image


#4

Well, is there a file where the path is?

You can also configure your antivirus running in daemon mode.

https://doc.owncloud.com/server/10.0/admin_manual/configuration/server/antivirus_configuration.html?highlight=virus#installing-clamav


#5

I don’t have access to the command line interface and the antivirus path didn’t change. It’s the same.
But once I have upgrade OC version, the antivirus is not anymore recognized…


#6

Can you try to disable the app and enable it again?


#7


#8

how should we proceed to disable the app?


#9

Admin -> Settings -> Apps -> find Antivirus -> Disable App


#10

oups sorry :slight_smile:
ok done but still the same error


#11

What error? “Test scan…” Error

or “You can’t access your files” Error?


#12

And I cannot upload any files on the server


#13

So you disabled the app, enabled it and you get this error, right?

Can you try to set it to executable again?

If you don’t have clamav daemon installed on your system you can use the daemon mode.


#14

same error test scan unsuccessful


#15

can you tell me how you did it without having access to command line?


#16

From the web interface of my hosting provider. I always proceeded this way to update my OC versions and it worked.


#17

From what version did you upgrade to 10.0.9?


#18

I am doing regularly the updates. The latest version was 10.0.0.8


#19

Here is the history of the versioning.


#20

Okay, I honestly have to idea. I would guess that the provider of the hosted server has screwed up while upgrading.

I don’t know what I can do besides the steps you have already done. Can you contact the support of the provider?