Clean install of 10.0.4 + AD connection - Access to admin options


#1

Steps to reproduce

Installed the latest community edition of owncloud's Virtualbox image, on a Windows Server 2012 server. The owncloud setup was done with Active Directory connection.

Expected behaviour

The server web admin dashboard should be accessible using the "Administrator"/[root_password] details, but it isn't.
Logging in with "owncloud"/"owncloud" or any AD active user logs into the actual web page, and client service is available (login at least, I haven't really tested it throughout).
Also, apt-get updated.

Actual behaviour

Administrator login details are rejected

Server configuration

Operating system:
Windows Server 2012 + VirtualBox

Web server:
owncloud Virtualbox iamge

Database:
sqlite

PHP version:
owncloud Virtualbox iamge

ownCloud version: (see ownCloud admin page)
latest

Updated from an older ownCloud or fresh install:
Fresh

Where did you install ownCloud from:
owncloud Community edition Virtualbox image


#2

Hi,

do you have virtualbox on a windows 2012 server running?
Is it a vm inside a vm or is the windows server installed on a physical machine?

Can you provide screen shots of the error you have encountered?


#3

Hi,
Virtualbox is running on a physical WS 2012 server, and I'm seeing as the screenshots below (sorry for two-in-one, the board doesn't allow me to post more than one image.

The top part is what I'm seeing when accessing owncloud's server IP address. Under "Applications", the ownCloud "application" accepts all AD logins and owncloud/owncloud.

The bottom part is the login page that appears after clicking, under "Administration" > "System and domain settings", and this is what I get when using the Administrator login details (root password).

Thanks


#4

Okay, seems alright so far. What is the problem?

Edit: The password for the Administrator account should have been set by you during the appliance setup


#5

Hi,
The issue is that the "Administrator" user, using the root password defined during the appliance setup, fails to login:

The authentication has failed, please login again

I've tried to find a way of resetting the user's password, but after searching through the manual and trying to check which users were there, I then got lost with understanding what's going on with ownCloud and Univention's local users:

Cheers


#6

I am currently trying to recreate your setup and will write when I am ready. 10-15 min top.


#7

Ok, thanks. However, note that I've connected to an AD server during the appliance setup, in case that makes a difference.


#8

Yeah, I am trying to do the same

Update: I am having some difficulties, but I am still on the case :slight_smile:


#9

Okay, you have to enter your Domain Admin Password, not the local root password.


#10

Hi,
Thanks for the input. I remembered I too had thought of that, but hadn't work.

I tried again with a domain admin user, and still no go. I'm trying with:
- What works for client login: username
- domain\username
- fulltld\username

All return failed login...


#11

I would reinstall. Something went wrong. Or you could reset the password of your domain admin und try then.


#12

Ok, I'm trying to reinstall, but now I get a weird error at the end of the appliance setup process:

ownCloud Appliance could not be joined because the license on the DC Master is not activated.

This did not appear earlier!