Client does not remove folder from local storage even when unchecked in the client folder list

Expected behaviour

When you untick/uncheck a folder in the folder list in the client, it should remove that folder from the local storage, while keeping it on the file server.

Actual behaviour

Sometimes, even when you untick a folder in the folder list in the client, the folder and its contents do not get removed from the local storage. The folder is unchecked in the list in the client:

Forcing the client to sync or waiting does not help.

Steps to reproduce

I haven’t understood what the problem relates to, or what circumstances make it occur.

Server configuration

Operating system: Linux

Web server:


PHP version:

ownCloud version:

Storage backend (external storage):

Client configuration

Client version: 2.10.0, build 6519

Operating system: Windows 10

OS language: English

Installation path of client: Default

1 Like

I’m experiencing the same problem with the desktop client on Windows 10 (v. 2.10.0, build 6519).
When a previously synced folder is unchecked from the list in the client, it’s not removed on the local filesystem, but remains in the ownCloud sync folder.

The server runs ownCloud 10.7 on Ubuntu 20.04, PHP 7.4 and MariaDB 10.6.

Any help would be appreciated, thanks.


I am also experiencing the same issue, folders are unchecked from the client list, but they remain in the local file system.

Client version is 2.10.0, build 6519 on Windows 10, server configuration is ownCloud 10.7 on Ubuntu 20.04, PHP 7.4 and MariaDB 10.6.

It seems to have started to happen in the last couple months, but I cannot recall the exact circumstances.

thank you for any help


More information:

  • ownCloud server has been updated to
  • Client has been updated to version 2.10.1 build 7187

Issue still persists. If it is of relevance, we have 20 concurrent users all syncing stuff, and we have big folders, like +10 GBs in size. I haven’t noticed if folder size contributes to folder being left in the local storage.

Upgrading the server to (with the latest version of the client) seems to have solved the problem for us.
We also have large folders with about 10 users syncing concurrently, if it can be of help to determine the issue.

Okay, thanks nicopa, good to know. I’ll continue monitoring and let you all know if the issue goes away (or doesn’t go :- ) ).

For Windows users, is there a good reason why you would not use the Virtual File System and rather continue to use “selective sync”?
From the above can’t judge why deselection didn’t work but thought that generally more and more people will switch to VFS anyway.

Thanks for letting me know about VFS! I tested out using VFS instead of selective sync.

I found VFS didn’t work for our environment:

  • We have a total of 2+ TB of data and hundreds, if not in the thousands, of folders. Setting up VFS took 2+ hours as it went through all of the data in the cloud.

ownCloud vfs

  • After setting up, ownCloud (and Windows Search Protocol) were constantly running at high power usage for hours, as the client was constantly checking for changes in the folders and files, since many people constantly make changes in different files.

Selective sync is better, because then the client won’t try checking the folders I have unticked in the list, and if I need a new folder synced from the cloud, I can simply just tick only that folder.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.