Client Fails to Reconnect to Server after initial setup, sync, and restart of PC - Web Interface Fine


#1

Expected behaviour

Client should connect and sync as normal after PC restart.

Actual behaviour

Client will fail to login to sync after initial setup and sync on new install.
After researt, a “No Connection” message is flashed briefly in the client window.

Web Interface works fine.

Steps to reproduce

  1. Install client via apt-get on Ubuntu 18.04
  2. Setup as normal, allow to sync.
  3. Restart PC

Server configuration

Operating system: CentOS 7

Web server: Apache2

Database: MariaDB

PHP version:7.0.23

ownCloud version: 10.0.3.3

Storage backend (external storage):

Client configuration

Client version: 2.4.1

Operating system: Ubuntu 18.04

OS language: English

Qt version used by client package (Linux only, see also Settings dialog): ??

Client package (From ownCloud or distro) (Linux only): 2.4.1

Installation path of client: ??

Logs

Please use Gist (https://gist.github.com/) or a similar code paster for longer
logs.

Template for output < 10 lines

  1. Client logfile: Output of owncloud --logwindow or owncloud --logfile log.txt
    (On Windows using cmd.exe, you might need to first cd into the ownCloud directory)
    (See also http://doc.owncloud.org/desktop/2.2/troubleshooting.html#client-logfile )

BLANK

  1. Web server error log:

BLANK

  1. Server logfile: ownCloud log (data/owncloud.log):

NOTE: None of these time stamps match me trying to reconnect this morning.

“reqId”:“uCaOTO6bmwU7Ek1RbRVx”,“level”:3,“time”:“2019-01-27T20:19:44+00:00”,“remoteAddr”:“108.197.13.110”,“user”:“user”,“app”:“PHP”,“method”:“GET”,“url”:"/index.php/settings/admin?sectionid=general",“message”:“opendir(/opt/bitnami/apps/owncloud/htdocs/themes): failed to open dir: No such file or directory at /opt/bitnami/apps/owncloud/htdocs/apps/templateeditor/lib/mailtemplate.php#155”}
{“reqId”:“TaYruH4SWspXqgk0sDFi”,“level”:3,“time”:“2019-01-27T20:20:02+00:00”,“remoteAddr”:“108.197.13.110”,“user”:“user”,“app”:“PHP”,“method”:“GET”,“url”:"/index.php/settings/admin?sectionid=general",“message”:“opendir(/opt[REMOVED - - [28/Jan/2019:13:14:19 +0000] “GET /ocs/v2.php/apps/notifications/api/v1/notifications?format=json HTTP/1.1” 200 108
[REMOVED] - - [28/Jan/2019:13:14:49 +0000] “GET /ocs/v2.php/apps/notifications/api/v1/notifications?format=json HTTP/1.1” 200 108/bitnami/apps/owncloud/htdocs/themes): failed to open dir: No such file or directory at /opt/bitnami/apps/owncloud/htdocs/apps/templateeditor/lib/mailtemplate.php#155”}
{“reqId”:“UQ4ye581J5ilz8lqQp6W”,“level”:2,“time”:“2019-01-27T22:19:52+00:00”,“remoteAddr”:“REMOVED”,“user”:"–",“app”:“core”,“method”:“POST”,“url”:"/index.php/login?redirect_url=%252Findex.php%252Fsettings%252Fadmin%253Fsectionid%253Dapps",“message”:“Login failed: ‘user’ (Remote IP: REMOVED’)”}
{“reqId”:“vFVy4yTo9iHsi5BhBCfS”,“level”:3,“time”:“2019-01-27T22:20:14+00:00”,“remoteAddr”:“REMOVED”,“user”:“user”,“app”:“PHP”,“method”:“GET”,“url”:"/index.php/settings/admin?sectionid=general",“message”:“opendir(/opt/bitnami/apps/owncloud/htdocs/themes): failed to open dir: No such file or directory at /opt/bitnami/apps/owncloud/htdocs/apps/templateeditor/lib/mailtemplate.php#155”}
{“reqId”:“jxaMCjVxYSlfcDzJWKyZ”,“level”:3,“time”:“2019-01-27T22:22:56+00:00”,“remoteAddr”:“REMOVED”,“user”:“user”,“app”:“PHP”,“method”:“GET”,“url”:"/index.php/settings/admin?sectionid=general",“message”:“opendir(/opt/bitnami/apps/owncloud/htdocs/themes): failed to open dir: No such file or directory at /opt/bitnami/apps/owncloud/htdocs/apps/templateeditor/lib/mailtemplate.php#155”}
{“reqId”:“uyFZ15GplRSdoP11tnrG”,“level”:2,“time”:“2019-01-28T12:27:01+00:00”,“remoteAddr”:“REMOVED”,“user”:"–",“app”:“core”,“method”:“PROPFIND”,“url”:"/remote.php/webdav/",“message”:“Login failed: ‘fedorauser24’ (Remote IP: ‘REMOVED’)”}


#2

Hi zwolfe21,

why don’t you use the new version of owncloud-client also 2.5.2
here is link for it :
https://software.opensuse.org/download/package?project=isv:ownCloud:desktop&package=owncloud-client

i would recommend it :wink:

and for the logf-file , you could press either ctrl+L or F12 to show log-window ,while settings-window is open .
ctrl + L is for 2.5.2 and higher versions


#3

The short version is I just got this laptop and 2.4.1 is what is in the repo.
Also, the logfile is quite vacant of any information what so ever :wink: I may try and upgrade to 2.5.1 and see if that fixes my issue but for some reason, the client seems to think there is no connection to the server. I even disabled ‘Launch at Startup’ to make sure it wasn’t some conflict establishing my wifi connection. Didn’t work.


#4

Indeed, none of your log snippets seems to be relevant to your sync issue.
However, there are some things you should check and fix:

{
        “reqId”:“uCaOTO6bmwU7Ek1RbRVx”,
        “level”:3,
        “time”:“2019-01-27T20:19:44+00:00”,
        “remoteAddr”:“108.197.13.110”,
        “user”:“user”,“app”:“PHP”,
        “method”:“GET”,
        “url”:"/index.php/settings/admin?sectionid=general",
        “message”:“opendir(/opt/bitnami/apps/owncloud/htdocs/themes): failed to open dir: No such file or directory at /opt/bitnami/apps/owncloud/htdocs/apps/templateeditor/lib/mailtemplate.php#155”
}

And this:

{
        “reqId”:“uyFZ15GplRSdoP11tnrG”,
        “level”:2,
        “time”:“2019-01-28T12:27:01+00:00”,
        “remoteAddr”:“REMOVED”,
        “user”:"–",“app”:“core”,
        “method”:“PROPFIND”,
        “url”:"/remote.php/webdav/",
        “message”:“Login failed: ‘fedorauser24’ (Remote IP: ‘REMOVED’)”
}

#5

You’d have to enlighten me about what the messages mean but I DO know they’re both caused by me. Also, the sync issues happens on both Ubuntu 18.04 and Fedora 29 fyi.

I wonder if it could be linked to a SSL error? The SSL I’m using (I haven’t fixed this yet) generates an unknown issuer error in any browser, and the client has to be forced to trust it. EDIT: Apache logs seems to nix this idea given that it never shows any such connection being attempted after the initial sync…


#6

Hey,

I would update both (not only the client as previously advised) as both are quite outdated before further looking into this issue. And i think the opendir message is probably also something i would fix.


#7

My first concern would be the two failed login attempts, users “user” and “fedorauser24”.

Second the failed opendir. But of course it’s up to you to know, what /opt/bitnami/apps/owncloud/htdocs/themes could be, or have been.

As you I also don’t think that SSL issues are related here, according your supplied log snippets.


#8

user and fedorauser24 are both me, admin and [actual] user respectively and I have no idea what opendir means [other than apparently open directory?]. Upgraded both the server and client. Doesn’t help FYI. That displayed IP address is from a public place I visit so I don’t care about displaying it.


#9

OK, but why does the login fail?


#10

Forgot the password or it was a mistype I’m not sure which.


#11

Now that you are running the latest desktop client, you could have a look into its logs. (Ctrl-L or F12)


#12

I tried several times to make it log in. Afterwards, I looked at the logs and they’re blank.

The only thing I see is a brief flash of a message on the client window that says “No Connection to Server at [my server address]”. That is the only message I have. The web interface, as stated previously, is still working fine.


#13

I tried the nextcloud client and it is exhibiting the same behaviour, except it returns error messages. Prompts for a password and gives an error message: “Reading from keychain failed error, no keychain service available”. After attempting to enter a password, the client window also displays a different error message. “No connection to Nextcloud at [server address], SSL Handshake Failed.”

Might be my misconfigured SSL after all.


#14

Nope: Resolved my SSL issues, did not fix owncloud however. Sync issue remains.


#15

This has been resolved in recent updates to the client. FYI, apparently, there was issues with storing the client cert info that was an upstream problem (not ownCloud).