Client on Ubuntu 18.04 spams syslog

Hello community,

on Ubuntu 18.04, the latest ownCloud desktop client spams the syslog with log entries like these:

Dec  5 13:25:23 ektorp ownCloud.desktop[5217]: 12-05 13:25:23:501 [ info sync.discovery ]:#011Discovered "univention/operations/fotos" INSTRUCTION_NONE OCC::SyncFileItem::None 2
Dec  5 13:25:23 ektorp ownCloud.desktop[5217]: 12-05 13:25:23:501 [ info sync.discovery ]:#011Processing "univention/operations/image database" | valid: true/db/db | mtime: 1557318383/0/0 | size: 0/0/0 | etag: "5cd2caefd5103"//"" | checksum: ""//"" | perm: DNVCKRS// | fileid: "00308443ocdn6ie06qgf"//"" | inode: 2490408/0/ | type: 2/3/0
Dec  5 13:25:23 ektorp ownCloud.desktop[5217]: 12-05 13:25:23:501 [ info sync.discovery ]:#011Discovered "univention/operations/image database" INSTRUCTION_NONE OCC::SyncFileItem::None 2
Dec  5 13:25:23 ektorp ownCloud.desktop[5217]: 12-05 13:25:23:616 [ info gui.socketapi ]:#011Sending SocketAPI message --> "STATUS:OK:/home/tdenisse/ownCloud" to QLocalSocket(0x555f25e9a950)
Dec  5 13:25:23 ektorp ownCloud.desktop[5217]: 12-05 13:25:23:616 [ info gui.socketapi ]:#011Sending SocketAPI message --> "UPDATE_VIEW:/home/tdenisse/ownCloud" to QLocalSocket(0x555f25e9a950)
Dec  5 13:25:23 ektorp ownCloud.desktop[5217]: 12-05 13:25:23:616 [ info gui.application ]:#011Sync state changed for folder  "https://filestore.knut.univention.de/owncloud/remote.php/dav/files/tdenisse/" :  "Success"
Dec  5 13:25:23 ektorp ownCloud.desktop[5217]: 12-05 13:25:23:617 [ info gui.socketapi ]:#011Received SocketAPI message <-- "RETRIEVE_FOLDER_STATUS:/home/tdenisse/ownCloud" from QLocalSocket(0x555f25e9a950)
Dec  5 13:25:23 ektorp ownCloud.desktop[5217]: 12-05 13:25:23:617 [ info gui.socketapi ]:#011Sending SocketAPI message --> "STATUS:OK:/home/tdenisse/ownCloud" to QLocalSocket(0x555f25e9a950)
Dec  5 13:25:23 ektorp ownCloud.desktop[5217]: 12-05 13:25:23:788 [ info sync.networkjob.etag ]:#011Request Etag of QUrl("https://metod.knut.univention.de/owncloud/remote.php/webdav/") FINISHED WITH STATUS "OK"
Dec  5 13:25:23 ektorp ownCloud.desktop[5217]: 12-05 13:25:23:817 [ info gui.folder.manager ]:#011<========== Sync finished for folder [ownCloud] of account [tdenisse@filestore.knut.univention.de] with remote [https://filestore.knut.univention.de/owncloud/remote.php/dav/files/tdenisse/]

We’re installing the client with apt from deb http://download.opensuse.org/repositories/isv:/ownCloud:/desktop/Ubuntu_18.04/ /

Output from owncloud --version:

ownCloud version 2.6.0 (build 1714)
Git revision 90ac7941c54975e165b1bc6a5e2172e4dc499827
Using Qt 5.12.5, built against Qt 5.12.5
Using 'OpenSSL 1.1.1  11 Sep 2018'

Current highest reported syslog file size is 11G, after ~30 minutes another 4GB were logged (stats from a heavy ownCloud user)

Is there a way to disable the logging to syslog (or any log at all, except when actively requested using the Logger (F12, --logwindow))?

Cheers
Timo

This is odd, it looks as if --logfile - was specified when launching? (CC @jnweiger)

@denissen With what parameters do you see the client in
ps waux
output?

1 Like
•98% ➜ ps wafux | grep -v grep | grep -i owncloud 
tdenisse  5217  0.1  0.4 1234560 70584 tty2    SLl+ 08:54   0:22              \_ /usr/bin/owncloud

When starting 2.6.0 clients from the shell, they print all these messages to stdout/stderr.
This is new behaviour. It should not be there.
Even worse, when these messages go to syslog.

I’d assume, when we can find out, why the messages are printed in my case, and fix it, then this would most likely fix your case too.

1 Like

Good morning,

@jnweiger Okay, but we start the client from the GNOME launcher (or through autostart, but not from a shell).

Is there any way I could assist in finding a/the error?

Cheers,
Timo

We already have an issue for this. But it was probably not precise enough for anybody to work on. Linked back here https://github.com/owncloud/client/issues/7453

@denissen The issue has a workaround: Could you check, if specifying a --logfile option prevents the spam?

2 Likes

@jnweiger Yes, when adding --logfile /dev/null, syslog stays quiet.

I’ll fork /usr/share/applications/owncloud.desktop to $HOME/.local/share/applications for the affected users until this is fixed upstream.

2 Likes

fixed in next 2.6.x release

3 Likes