[closed] Updater stuck. 10.8.0.4 -> 10.9.1[stable]

Steps to reproduce

  1. Settings
  2. Updater
  3. Start

Expected behaviour

Updater should either fail at “Checking system” or run to completion.

Actual behaviour

Updater runs as far as “Updating core : Copying the application user_external” then hangs for over an hour. Alongside “Updating core” is the circling icon. Below “Updating apps” is highlighted in rad with a warning icon, and the message “undefined” below.

Server configuration

Operating system:
Linux: AlmaLinux 8.6 (Sky Tiger)
Web server:
Apache/2.4.37

Database:
sqlite3 3.26.0
PHP version:
7.2.24
ownCloud version: (see ownCloud admin page)
10.8.0.4 → 10.9.1
Updated from an older ownCloud or fresh install:
Updating in progress
Where did you install ownCloud from:
Online, via updater.
Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

or 

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

$ php occ config:list system
This version of ownCloud requires at least PHP 7.3.0
You are currently running PHP 7.2.24. Please update your PHP version.

Are you using external storage, if yes which one: local/smb/sftp/…
not yet
Are you using encryption: yes/no
no
Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…
no

Client configuration

Browser:
Firefox
Operating system:
AlmaLinux

Logs

Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

This looks like “Checking system” should have picked up on the PHP (based on the occ config:list system command). I thought the PHP upgrade was only needed for 10.10.X

Can I safely abort the installation or do I need to go back to backups?

Stopping the installation leaves things not working. I gave it about 6 hours and killed it off, and now the server is U/S.

I’ve tried renaming /srv/www/html/owncloud/core to new_core and /srv/www/html/owncloud/apps to new_apps. Then I moved /Cloud/updater-data/checkpoint/10.8.0.4-628ca86e7af1e/* to /srv/www/html/owncloud. There were just the two subdirectories core and apps. When I try to start OwnCloud though, I still get the message about PHP. Do I need to go back to the last full backups and roll forward?

You have to update PHP to 7.4 (7.3 might still be ok), then you can update ownCloud.

I’m not sure about the state, but I guess the upgrade stopped or crashed due to the no longer supported PHP version. Updating PHP might unblock the upgrade.

If that doesn’t work, maybe you can rollback your installation and upgrade PHP to 7.4 before upgrading ownCloud. Anyway, the recommendation is to upgrade via command line, not through web.

OK, thanks. I feared that that would be the case. Do I just have to recover /srv/www/html/owncloud... from backups? I assume that the user data (in my case in /Cloud) will be unaffected.

To answer my questions above. Yes, I only needed to recover /srv/www/html/owncloud... from backups and yes, the user data (in my case in /Cloud) was unaffected.

Points:

  1. The updater really ought to check for incompatibilities before trashing the installation.

  2. The checkpointing mechanism appears insufficient.

  3. Perhaps remove the updater all together if it is deprecated? Maybe this has been already done?