Code integrity Check - 10.0.10.4 - Webhost


#1

Hi all,

I am on Owncloud 10.0.10.4 and I have a problem with code integrity check.
Basically since a few versions before, I am getting this message after every version upgrade.
I am adding the below lines to my .httaccess file after each upgrade to enable uploads:

Order allow,deny
allow from all

If I don’t do that, I won’t be able to upload files to my owncloud instance.
I use a relatively cheap hosting at bluehost.com and I am unable to make any changes to main server config files - hence I think the only choice I have is to do what I describe above - please feel free to correct me.

This is the list of all messages I get after each upgrade:

Blockquote
Transactional file locking should be configured to use memory-based locking, not the default slow database-based locking. See the documentation :arrow_upper_right: for more information.
We recommend to enable system cron as any other cron method has possible performance and reliability implications.
Some files have not passed the integrity check. Further information on how to resolve this issue can be found in our documentation. (List of invalid files… / Rescan…)
No memory cache has been configured. To enhance your performance please configure a memcache if available. Further information can be found in our documentation.

Blockquote

I don’t have access to cron either, I can’t configure memcache and so on. If there was a way to remove all these messages that’d be great.

Thanks,
Ben


#2

Hey,

that it is required to add something like this to a .htaccess file looks strange to me. Maybe you can contact the support of bluehost about this?

From what i know its only possible to remove this message by configuring all mentioned things by following the mentioned documentation.


#3

You could just use the webUI, right?

This check is basically a security feature. You can turn it off or exclude directories from this check in your config.php.


#4

Somehow I needed it from the start and I think the solution I found on this forum years ago. From memory, I started Owncloud about 3 years ago… quite a few versions back. I wasn’t allowed to upload anything until I added that change into .htaccess and since then after every update, I need to do the same.

Although I run this cloud thing and have a few other server based apps, I am not what you would call a tech savvy guy. What do I tell bluehost? From memory I needed to change something in the apache config, to which I obviously don’t have access.

Thanks for all the answers otherwise. I knew I could set the cron from the UI but I believe it was erroring. I just set it again and will check back tomorrow to see.

Ben


#5

So I did turn it on yesterday and as I remembered, I am getting these errors so I can clearly not use it. Do you have any idea why?

Thanks,
Ben

image


#6

Hey,

i’m also not very tech savvy concerning Apache but if i understand your posted .htaccess snipped this “allows” (enables) access to your ownCloud instance which should be enabled by default within the web server configuration. Maybe you could ask bluehost why this is required to be added to your .htaccess and what alternatives they suggest which doesn’t require such .htaccess modifications?

AFAIK to be able to use “Cron” you need to have a cron job running on this system (see the related documentation). Just switching to this setting won’t enable this automatically.