Code integrity check error


#1

Hi guys I have a problem with the integrity check.
I don't understand rootbash and userbash?

Results

  • core
    • EXTRA_FILE
      • rootbash
      • userbash

Raw output

Array
(
[core] => Array
(
[EXTRA_FILE] => Array
(
[rootbash] => Array
(
[expected] =>
[current] => c78fc8ba75e0ddd527f81697ace0429b95439e0eba9e2d57c0fcf40c915d45239c4b54b1b6e324d9f361951d947adcc8d52372f40a737a21f4dc5fc1815f9f37
)

                [userbash] => Array
                    (
                        [expected] => 
                        [current] => 00e1d9f7d081bf0bf503f9afd93d2cdef5f4eb89bc5e9e9078c3bc39377f875559cd5f38d649403095961a2afa71fb8b92347ecbad684937ff0cd69d17df790c
                    )

            )

    )

)
[/code]


#2

The integrity message contains a link to the documentation [1] explaining the needed steps how to fix this. Is there something missing or not understandable in that documentation?

[1] https://doc.owncloud.org/server/latest/admin_manual/issues/code_signing.html#fixing-invalid-code-integrity-messages


#3

thank you for your answer, yes I already try to fix it with the documentation, but nothing change..


#4

When doing such short posts its not possible to help here as no one can guess what steps you have done to fix this.

The documentation contains all needed information how to fix these message. Please follow it step by step to delete the mentioned files and doing the rescan as also explained in the documentation.

You probably just have missed one step or have not deleted / fixed all files.


#5

what informations do you need ?


#6

I don't need any information as i won't continue to help here (IMHO all infos where provided to fix this issue).

Is also not clear if you have exactly the same problem as the original poster so you're might be also just wrong in this thread.


#7

sorry but I read the documentation many times.. I tried to re-install all files from the source but still the same issue.

I don't have one or two files in error.. but all files..

I won't past the full error log here, because it's a lot to much.. and I'm limited to 30'000 characters here..

Please, can you help me to find a solution ? my issue don't looks like the other on this forum.

As I can see, others people has only 2-3 files in error, and they just need to replace these files..

thank you very much..


#8

Please create a new thread as your issue is then unrelated to the one of the original poster.


#9

oh sorry ! I didn't realized that I'm not repplying in my thread... sorry..