Collabora Integration Issue


#1

Hello

I am relatively new to owncloud, I am working on a portal for our small office that uses collabora for document and spreadsheet editing. I have almost everything working, but I have one last issue to solve.

Setup is as follows:

owncloud 9.1.4 on Ubuntu server 16.04 x64
LDAP auth module up and running auth against AD on Windows Server 2008
External storage module up and running. All data stored on CIFS/SMB on Windows Server 2008

When users log in, they are presented with the correct folder structure [based on their AD group]. They have access to create, edit, delete files etc. This is working.

If I create a document with collabora in the Documents area which is stored on the Owncloud server, all works perfectly. I can edit, save, etc without issue.

However, I cannot do the same when interacting with the CIFS storage. I get the message "Well, this is embarrassing, we cannot connect to your document"

So the basic issue is that I cannot edit or even open documents that are stored in the CIFS [external storage] area.
Can anyone assist with what I can do to solve this?

My [cleansed] docker log shows the following:

wsd-00025-0027 11:54:46.240288 [ client_ws_0037 ] ERR Invalid fileinfo for URI [https://oc.mydomain.com/owncloud/index.php/apps/richdocuments/wopi/files/299430?access_token=7acO5vTh4Pa4QHRqwwYyWkO0dZbyo3Hv&access_token_ttl=0&permission=readonly].| wsd/DocumentBroker.cpp:314
wsd-00025-0027 11:54:46.240331 [ client_ws_0037 ] ERR Failed to load document with URI [https://oc.mydomain.com/owncloud/index.php/apps/richdocuments/wopi/files/299430?access_token=7acO5vTh4Pa4QHRqwwYyWkO0dZbyo3Hv&access_token_ttl=0&permission=readonly].| wsd/DocumentBroker.cpp:556
wsd-00025-0027 11:54:46.240397 [ client_ws_0037 ] ERR Error in client request handler: Failed to load document with URI [https://oc.mydomain.com/owncloud/index.php/apps/richdocuments/wopi/files/299430?access_token=7acO5vTh4Pa4QHRqwwYyWkO0dZbyo3Hv&access_token_ttl=0&permission=readonly].| wsd/LOOLWSD.cpp:1038
wsd-00025-0029 11:56:05.766888 [ client_ws_0038 ] ERR WOPI::CheckFileInfo is missing JSON payload
wsd-00025-0029 11:56:05.767250 [ client_ws_0038 ] ERR Invalid fileinfo for URI [https://oc.mydomain.com/owncloud/index.php/apps/richdocuments/wopi/files/299430?access_token=7acO5vTh4Pa4QHRqwwYyWkO0dZbyo3Hv&access_token_ttl=0&permission=readonly].| wsd/DocumentBroker.cpp:314
wsd-00025-0029 11:56:05.767304 [ client_ws_0038 ] ERR Failed to load document with URI [https://oc.mydomain.com/owncloud/index.php/apps/richdocuments/wopi/files/299430?access_token=7acO5vTh4Pa4QHRqwwYyWkO0dZbyo3Hv&access_token_ttl=0&permission=readonly].| wsd/DocumentBroker.cpp:556
wsd-00025-0029 11:56:05.767473 [ client_ws_0038 ] ERR Error in client request handler: Failed to load document with URI [https://oc.mydomain.com/owncloud/index.php/apps/richdocuments/wopi/files/299430?access_token=7acO5vTh4Pa4QHRqwwYyWkO0dZbyo3Hv&access_token_ttl=0&permission=readonly].| wsd/LOOLWSD.cpp:1038
wsd-00025-0030 11:56:16.037149 [ client_ws_0039 ] ERR WOPI::CheckFileInfo is missing JSON payload
wsd-00025-0030 11:56:16.037423 [ client_ws_0039 ] ERR Invalid fileinfo for URI [https://oc.mydomain.com/owncloud/index.php/apps/richdocuments/wopi/files/299430?access_token=7acO5vTh4Pa4QHRqwwYyWkO0dZbyo3Hv&access_token_ttl=0&permission=readonly].| wsd/DocumentBroker.cpp:314
wsd-00025-0030 11:56:16.037453 [ client_ws_0039 ] ERR Failed to load document with URI [https://oc.mydomain.com/owncloud/index.php/apps/richdocuments/wopi/files/299430?access_token=7acO5vTh4Pa4QHRqwwYyWkO0dZbyo3Hv&access_token_ttl=0&permission=readonly].| wsd/DocumentBroker.cpp:556
wsd-00025-0030 11:56:16.037518 [ client_ws_0039 ] ERR Error in client request handler: Failed to load document with URI [https://oc.mydomain.com/owncloud/index.php/apps/richdocuments/wopi/files/299430?access_token=7acO5vTh4Pa4QHRqwwYyWkO0dZbyo3Hv&access_token_ttl=0&permission=readonly].| wsd/LOOLWSD.cpp:1038
wsd-00025-0026 11:56:21.606610 [ client_ws_003a ] ERR WOPI::CheckFileInfo is missing JSON payload
wsd-00025-0026 11:56:21.606869 [ client_ws_003a ] ERR Invalid fileinfo for URI [https://oc.mydomain.com/owncloud/index.php/apps/richdocuments/wopi/files/299430?access_token=7acO5vTh4Pa4QHRqwwYyWkO0dZbyo3Hv&access_token_ttl=0&permission=readonly].| wsd/DocumentBroker.cpp:314
wsd-00025-0026 11:56:21.606903 [ client_ws_003a ] ERR Failed to load document with URI [https://oc.mydomain.com/owncloud/index.php/apps/richdocuments/wopi/files/299430?access_token=7acO5vTh4Pa4QHRqwwYyWkO0dZbyo3Hv&access_token_ttl=0&permission=readonly].| wsd/DocumentBroker.cpp:556
wsd-00025-0026 11:56:21.606967 [ client_ws_003a ] ERR Error in client request handler: Failed to load document with URI [https://oc.mydomain.com/owncloud/index.php/apps/richdocuments/wopi/files/299430?access_token=7acO5vTh4Pa4QHRqwwYyWkO0dZbyo3Hv&access_token_ttl=0&permission=readonly].| wsd/LOOLWSD.cpp:1038
wsd-00025-0030 11:56:26.923825 [ client_ws_003b ] ERR WOPI::CheckFileInfo is missing JSON payload
wsd-00025-0030 11:56:26.924065 [ client_ws_003b ] ERR Invalid fileinfo for URI [https://oc.mydomain.com/owncloud/index.php/apps/richdocuments/wopi/files/299430?access_token=7acO5vTh4Pa4QHRqwwYyWkO0dZbyo3Hv&access_token_ttl=0&permission=readonly].| wsd/DocumentBroker.cpp:314
wsd-00025-0030 11:56:26.924133 [ client_ws_003b ] ERR Failed to load document with URI [https://oc.mydomain.com/owncloud/index.php/apps/richdocuments/wopi/files/299430?access_token=7acO5vTh4Pa4QHRqwwYyWkO0dZbyo3Hv&access_token_ttl=0&permission=readonly].| wsd/DocumentBroker.cpp:556
wsd-00025-0030 11:56:26.924293 [ client_ws_003b ] ERR Error in client request handler: Failed to load document with URI [https://oc.mydomain.com/owncloud/index.php/apps/richdocuments/wopi/files/299430?access_token=7acO5vTh4Pa4QHRqwwYyWkO0dZbyo3Hv&access_token_ttl=0&permission=readonly].| wsd/LOOLWSD.cpp:1038
wsd-00025-0030 11:56:26.924561 [ client_ws_003b ] ERR ClientRequestHandler::handleClientRequest: I/O error: Bad address| wsd/LOOLWSD.cpp:1230


#2

Looks like a known issue in that 3rdparty app:


#3

Thanks for the reply. I think I skipped over that article as the error logs were not exactly matching mine.

There seems to be no fix based on that post. Does that mean everyone successfully using this document app are using it on locally stored content?

Matthew


#4

If the message is different it might be also a similar but different bug so you could also consider to report a new bugreport over there.

I had it running for a while with locally stored content without any issue.