Collabora Online CSR issue followed by not working at all

Hello, I am struggling to get the Collabora integration working properly on my OwnCloud 10.13.2 install running inside Docker.

Here is what I have done:

  1. Installed Collabora core server running in Docker per the instructions “CODE_Docker_image.html” from the Collabora SDK website (sorry was not allowed to post a link).
  2. Setup Collabora Core to use SSL using my pre-existing SSL certificates. Everything works just fine when I visit https://:9980/browser/dist/admin/admin.html
    Likewise, I get “OK” when I access https://:9980/
  3. Installed the OwnCloud Collabora plugin from Marketplace and set the URL of the Collabora server to https://:9980

Note: OwnCloud is running on the exact same domain behind Caddy reverse proxy.

At this point, everything should be setup to work. However, opening a document did not load Collabora. Instead, I got a CSR error saying that loading https:///… was blocked as it was not in the “frame-src” CSR. I did notice that the “frame-src” has only “https://:9980” and not “https://”, but the path blocked was for “https:///…”

In order to set aside the Content-Security-Policy issues, I changed my Caddy reverse proxy to modify the headers and essentially allow everything under Content-Security-Policy.

At this point, the web browser loaded everything, however the frame it loaded is just owncloud itself again (so I am seeing OwnCloud within OwnCloud). It almost seems like there is a weird issue where the frame URL that OwnCloud is generating for the Collabora frame is missing the port number. Running config:app:get richdocuments wopi_url shows the correct URL and port number (9980).

Anyone experienced this or suggestions on next troubleshooting steps?

Edit: I tried changing the domain of my Collabora server completely so it is behind a reverse proxy on a separate subdomain and running on the standard port 443. This did not work and the URL of the frame served was still the old URL, even though in both the web settings and config:app:get richdocuments wopi_url the updated URL was showing.

Then I created a clean docker image and used the new domain for the Collabora server. This worked. I believe there is a bug that at the very least updating the URL for the Collabora server is not propagating everywhere. Additionally, it is possible that the port number is not being properly recognized.