Conflicts in Files


#1

Dear Team,

I am using Desktop Client with my domainname hosted owncloud. On sync, owncloud makes conflicted files in the local folder. as going through the url (https://doc.owncloud.org/desktop/2.5/conflicts.html), I am not getting where to change value of OWNCLOUD_UPLOAD_CONFLICT_FILES=1. Please suggest.


#2

You have to set this as environment variable, depending on your desktop OS.


#3

Plan is, to make this accessible in the user interface in one of the next versions.


#4

What to put in Environment Variable? Path as I am using domainname? Value?
I am using Windows 10.

Please suggest.


#5

Great…

But any solution to overcome conflicts as of now?


#6

I’m not an expert for Windows, but a quick search brings up some useful hints:
https://duckduckgo.com/?q=windows+10+environment+variable&ia=qa


#7

I think, nobody here can tell, why your files are conflicting. It’s up to you to find the cause.
Some hints:

  • time/clock differences
  • syncing to external storage, might give extra trouble
  • …

Start with checking an single example, compare the files content, timestamp, attributes etc.


#8

Hello,

Thank you for the information. I am able to find the cause. Its due to time/clock differences.
How to resolve this cause?


#9

Well, you should bring the clock of every involved pc in sync with the clock of the server where owncloud is running. Current Windows clients are normally ok, eg synced with a timeserver. Now you’ll have to setup for your server as well. Have a look at

man ntpd


#10

Thank you for the concern.
To my understanding, the conflicts are arrising due to follows:
I run the server and data gets synced at say 8AM in the morning. I went out and later in the evening again when I run the server, the file time i.e. 8 AM changes to 5PM and hence I will be getting the conflicted files of all the data as the same data already resides on the server.
I studied this case on OwnCloud website (https://doc.owncloud.org/desktop/2.5/conflicts.html) and they suggested the solution as to change value to the parameter to 1 i.e. OWNCLOUD_UPLOAD_CONFLICT_FILES=1. But where to do this setting in OwnCloud package, is unknown to me. Please help.


#11

Hey,

i don’t think that this setting will solve your initial issue about conflicting files. Instead its probably better to follow the previous advises given by the other users to avoid getting conflict files at all instead of trying to let the client uploading them.


#12

Setting the variable doesn’t avoid or solve any conflicts, It just makes that the conflicted files are also copied to the server. Then both versions of the file are available on the server.


#13

Earlier Advice is to set the environment variable, but I am not getting what path and value of the environment variable will be.
Please suggest any solution to this problem.


#14

Hey,

there are other advises to e.g. sync the time of the server and the client or similar in this thread. :slightly_smiling_face:


#15

Server and client time is already same as both are using the Internet Time with the same region clock.
So these both are having same clock time always in my case.


#16

Hey,

then you probably need to search through your logfiles of client and server to see any hints why the conflict files are created at the first place.

I think it could also worth to check if you’re running the latest available versions of the sync client (2.5.0) and server (10.0.10) as you havn’t provided this mandatory information about your environment yet.


#17

As mentioned earlier, pick a single conflict as example. What is different? Timestamps? Contents? Who or what touches the file between 8am and 5pm?