Connection error using wifi

android
help

#1

Summary: if taking a pic on phone camera the auto upload fails if connected to home WiFi. If I disable my phone's WiFi and use 4g it works. I can manually upload on WiFi via app using the upload link, but would prefer to get the auto upload working.

Phone is Nexus 5. It has worked before but not now
Steps to reproduce
1.t Ake pic on phone
2.i instant upload failed - connection error
3.turn off WiFi and use 4g - works

Expected behaviour
After taking a pic on mobile camera, The app should auto upload pic to server

Actual behaviour
The upload fails under WiFi mode automatically but if I turn off WiFi and use 4g or manually upload using owncloud app it works

Server configuration
Operating system: linux
Web server: xampp
Database:mysql
PHP version: 7.0
ownCloud version (see ownCloud admin page): latest
Updated from an older ownCloud or fresh install: fresh
ownCloud log (data/owncloud.log, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808):

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):

Integrity status for oC9+

Login as admin user into your ownCloud and access
http://example.com/index.php/settings/integrity/failed
paste the results here.

#2

Please report issues with the Android app directly to the app developer at:

https://github.com/owncloud/android/issues

Especially if a functionality worked before and stopped at some point.