Corrupt ZIP problem again on FreeBSD 11

help

#1

Is there some way to disable the completely INSANE default behavior of zipping folders? Or limit it to only very large directories?

Isn't the whole point of having an owncloud server that pretty much anything can access it, including fringe OSes and underpowered iTrash devices and Samsung's latest rubbish du jour?

When I download a folder to my FreeBSD 11 system from my owncloud server, hosted on TrueOS (FreeBSD 12), I cant open the zip file and I get the error:

unzip: Truncated ZIP file data

I tried from the command line and from Gnome's filemanager GUI. zip files obtained from any place other than OWNCLOUD work fine.

Accessing the owncloud server from OS X Sierra, the downloaded zip folder opens without error.

All downloading is done through Firefox.


#2

There is no possibility to disable this If you can't open the zip file this needs to be fixed in ownCloud (or better the library used by ownCloud for this zip handling).

For this just create a new issue at the bugtracker [1] after you have made sure that you're running a recent ownCloud 9.1.4 installation.

[1]


#3

So the issue is already known (See [1]) but no one cared to report a bug to the bugtracker [2] of mentioned library above.

Edit Ok, some one reported the same for Nextcloud to that lib in [3].

[1]

[2]

[3]