Crash on windows 10

report e523a6f0-dd42-4c58-b9bb-854662403b68
version 2.7.5.3180x64

owncloud allways crash

Hi

Unfortunately, with this information it is not possible to give a viable solution.
We need the Logs, Information of your operating system, a description of the scenario, information of the evenView .

Here is a template:

### Steps to reproduce
1.
2.
3.

### Expected behaviour
Tell us what should happen

### Actual behaviour
Tell us what happens instead

Cheers
Erwin Palma

ADMIN EDIT: removed server stuff from template as it would be confusing

Are you using VFS?
If yes, have you tried uninstalling, removing your owncloud.cfg from %appdata%\owncloud\ and reinstalling?

NO, I’m not using VFS

Having (or had) the same issue - Owncloud version 2.7.5 build 3180 installed on Windows 10 (20H2), out of the blue, Owncloud client just started crashing. I tried a repair - no luck. I uninstalled, renamed the C:\Users\MyName\AppData\Roaming\owncloud folder to preserve the settings. I then did a clean install. Owncloud is no longer crashing, but when I tried to copy the config file from the old directory to the new, it crashed again. I put the new config back and no more crashing. So then I decided to go with the new install and recreate the synchronizations - only now I have a new problem, before the new install I could synchronize my U: drive - a mapping to my NAS - but now I get an error - Warning: You have no permission to write to the selected folder! So now I am unable to sync my NAS shares.

Can you open a powershell, and start ownCloud client with the following command:

& 'C:\Program Files (x86)\ownCloud\owncloud.exe' --logfile - --logflush | Write-Host 

You might have to adjust the path C:\Program Files (x86)\ownCloud\owncloud.exe to your owncloud.exe

This should output the exact error message right in the powershell and if you paste it here we can look at it together.

The command provided does not work. I changed the path to where my install is located, and this is the output - I tried various iterations - no luck. I tried --help and /help and /? to see if I could get help on syntax and it doesn’t work either.

PS C:\WINDOWS\system32> ‘C:\Program Files\ownCloud\owncloud.exe’ --logfile - --logflush | Write-Host
At line:1 char:44

  • ‘C:\Program Files\ownCloud\owncloud.exe’ --logfile - --logflush | Wri …
  •                                        ~~~~~~~
    

Unexpected token ‘logfile’ in expression or statement.
At line:1 char:1

  • ‘C:\Program Files\ownCloud\owncloud.exe’ --logfile - --logflush | Wri …

The ‘–’ operator works only on variables or on properties.
+ CategoryInfo : ParserError: (:slight_smile: [], ParentContainsErrorRecordException
+ FullyQualifiedErrorId : UnexpectedToken

In order to execute a quoted command you need to prefix the command with an &

& 'C:\Program Files\ownCloud\owncloud.exe' --logfile - --logflush | Write-Host

DOH! My bad. Okay, so I get a whole lot of output that says it is working fine with the one local directory I have set up to sync to my owncloud sever. When I try to add a folder on a mapped drive to a share on my NAS, the UI says that I don’t have write permissions to the directory (which I do) and the powershell output has nothing on this action until I cancel the operation 02-09 05:34:20:430 [ info gui.account.settings ]: Folder wizard cancelled.

FYI, in the middle of this, the client upgraded - so now I am running 2.7.6 (build 3261) - but still no difference.