Creating a public link just keeps asking for password


#1

I input the information I knew. Fresh install of version 10.0.10.
I create a PUBLIC link/URL. Then when someone tries to access it, Owncloud will prompt them for a username and password. This is a PUBLIC link I’m creating. I do not want Owncloud to prompt the user for credentials.

A box comes up and says:
The server is asking for your user name and password. The server reports this this is from Owncloud. And the pop up box header indicates Windows security.

I do remember in the previous versions this did not happen.

I hope this is the correct place for this. It is real tricky trying to find the correct forums area since there is Owncloud Enterprise out there as well. Well, I hope this can checked out or someone knows off the top of their head. Everything usually boils down to access and rights in the end.

Steps to reproduce

Expected behaviour

Tell us what should happen

Actual behaviour

Tell us what happens instead

Server configuration

Operating system:
Centos 7.6 VPS

Web server:
Latest PHP - 7.1

Database:
MariaDB 10.2

PHP version:
7.1

ownCloud version: (see ownCloud admin page)
10.0.10
Updated from an older ownCloud or fresh install:
Fresh install
Where did you install ownCloud from:

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

Says NO ERRORS HAVE BEEN FOUND

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

Edited for security
<?php
$CONFIG = array (
  'instanceid' => 'octo1dapkkzg',
  'passwordsalt' => 'FDVyuSz',
  'secret' => '+hlQyUUhqsgZnnU4t',
  'trusted_domains' => 
  array (
    0 => 'domain.com',
  ),
  'datadirectory' => '/home/domain/public_html/data',
  'overwrite.cli.url' => 'http://domain.com',
  'dbtype' => 'mysql',
  'version' => '10.0.10.4',
  'dbname' => 'domain_owncloud',
  'dbhost' => 'localhost',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'domain_mike',
  'dbpassword' => 'mypassword',
  'logtimezone' => 'UTC',
  'installed' => true,
);



**List of activated apps:**
Gallery
Guests


If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.


**Are you using external storage, if yes which one:** local/smb/sftp/...
No

**Are you using encryption:** yes/no
No

**Are you using an external user-backend, if yes which one:** LDAP/ActiveDirectory/Webdav/...
No

#### LDAP configuration (delete this part if not used)

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM oc_appconfig WHERE appid = ‘user_ldap’;

Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.


### Client configuration
**Browser:**
Chrome 70


**Operating system:**
Windows 10

### Logs
#### Web server error log

Insert your webserver log here


#### ownCloud log (data/owncloud.log)

Insert your ownCloud log here


#### Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log
c) …


#2

Works for me in windows 10 with both Chrome 71 and Edge 42

It might be a good idea to fill the issue template, specially for the ownCloud logs, and the list of apps installed. One or more screenshots showing the problem also helps.


#3

Hi opentoe ,

if you had done everything correctly ,you wouldn’t have gotten this problem

i just made a share for you on “demo.owncloud.org” ,the version of this server is the latest “10.0.10” the same as yours

https://demo.owncloud.org/s/pKLY1x9qpjw0Oq3

you don’t have to type in a password for your public share