Cron not running after upgrade Owncloud 10.3

System info:
Ubuntu 16.04LTS
PHP 7.0
(All upgades installed for system with apt-get)
Owncloud 10.3
Database SQLite

Steps to reproduce

  1. Upgrade Owncloud to 10.3 from previous version.
    fixed: ( * * * * * php occ system:cron)
  2. Look in web interface (Settings – General)
  3. Cron wont run (system’s cron service)

If I use command line interface navigate to /var/www/owncloud/ and manually
run: “sudo -u www-data php occ system:cron”

and check back in the webinterface it says executed.

So it only works when manually activated.
Anyone can help me with this?


the environment between cron and your shell is not the same.
If you look at the doc it says to do that (with some modification):

/usr/bin/php -f /path/to/your/owncloud/occ system:cron

Put the full path to PHP and your occ, it should work.
Cheers !

1 Like


It worked like a charm :wink:
Thx for the fast reply!

1 Like

you’re welcome, I’m glad it works !
Could you set the topic as solved ?

1 Like