CSync failed to access and duplicate folders

help

#1

Steps to reproduce
Can be reproduced, see below

Expected behaviour
Csync issue and duplicate folders

Actual behaviour
A few days ago we started to get CSync issues, like CSync failed to access a certain folder or folders and it looks like it is related a to a specific folder or maybe even several folders. At least that is where the issue starts. In this case a "reports" folder.
Sync failed to access: "https://xxx.xxx.xxx.xxx/owncloud/remote.php/webdav/Programs/_current/FL/Guld Breeze/reports"

In addition to this we have duplicate folders in the Gulf Breeze folder as well. When I access the owncloud web GUI I can see the "reports" folder and it allows me to delete it, but the folder comes back. If I try to rename the folder it says it does not exist anymore. So it looks like some parts of the database is corrupt?

We did the following troubleshooting so far:
* We run repair on the mysql database, yet this did not resolve it and no errors found.
* We run "sudo -u www-data php occ files:scan --all" yet this did not resolve the issue either
* We run "sudo -u www-data php occ maintenance:repair" yet this did not resolve the issue either

Any thoughts on this? On how to resolve this issue.

Server configuration
Operating system: Ubuntu 12.04.5 LTS
Web server: Apache 2.4.12
Database: Mysql 5.5.41
PHP version: PHP 5.5.23-1
ownCloud version (see ownCloud admin page): 9.1.4
Updated from an older ownCloud or fresh install: updated from older version from 8.0.16 to 8.1.12 to 8.2.10 to 9.0.8 to 9.1.4
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption): No

ownCloud log (data/owncloud.log)

Please paste possible errors in the following code block, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808 for more info

Integrity status for oC9+

Login as admin user into your ownCloud and access
http://example.com/index.php/settings/integrity/failed
paste the results here.

No errors have been found.


#2

We encountered this bug as well. It would be nice if someone could provide a temporary fix until it gets fixed in the new version. Please help.


#3

Hi,

if you think this is a bug then please report it (obviously :slight_smile:) to the bugtracker. There won't be any temporary fix in here as bugs won't be noticed and fixed based on reports here at the forums.


#4

hey @markus007 @slide cross-posting my answer from https://github.com/owncloud/client/issues/5804:

It was opened some days ago in https://github.com/owncloud/core/issues/28018 and a fix is already in the making (https://github.com/owncloud/core/pull/28022), keep an eye in the core issue for updates.

Thanks for reporting! :wink:


#5

The fix is done: https://github.com/owncloud/core/pull/28022

However this is only to prevent the breakage to happen in the first place.

Requires a repairs step to fix the broken filecache entries: https://github.com/owncloud/core/pull/28253