Debian 11, Client v3.0.0.9215 SSL Usertrust RSA cannot find local certificate

Expected behaviour

Connect to server using the new client version

Actual behaviour

The client does not accept the certificate issued by Comodo CA and USERTrust RSA in its chain.
Version 2.11.1 does not have this issue

Steps to reproduce

  1. Update to the latest clientversion on debian (in my case)
  2. Try to connect to a server using a Comodo certificate

Server configuration

Operating system: Debian 11

Web server: Apache / Haproxy

Database: MySQL

PHP version: 7.4

ownCloud version: 10

Client configuration

Client version: 3.0.0.9215

Operating system: Debian 11

OS language: DE,EN

Qt version used by client package (Linux only, see also Settings dialog): 5.15.2

Client package (From ownCloud or distro) (Linux only): Owncloud

Logs

No logs produced when trying to login, just the ssl error dialog appears

Could you share the server URL?

No sorry, I don’t want to publicly share our corporate cloud url to the web. But a ssllabs test resulted in an A+ with no chain issues. Everything, everywhere works except the new client.

Certificates provided 3 (4554 bytes)
Chain issues None
#2
Subject Sectigo RSA Domain Validation Secure Server CA
Fingerprint SHA256: 7fa4ff68ec04a99d7528d5085f94907f4d1dd1c5381bacdc832ed5c960214676
Pin SHA256: 4a6cPehI7OG6cuDZka5NDZ7FR8a60d3auda+sKfg4Ng=
Valid until Tue, 31 Dec 2030 23:59:59 UTC (expires in 8 years)
Key RSA 2048 bits (e 65537)
Issuer USERTrust RSA Certification Authority
Signature algorithm SHA384withRSA
#3
Subject USERTrust RSA Certification Authority
Fingerprint SHA256: 68b9c761219a5b1f0131784474665db61bbdb109e00f05ca9f74244ee5f5f52b
Pin SHA256: x4QzPSC810K5/cMjb05Qm4k3Bw5zBn4lTdO/nEW/Td4=
Valid until Sun, 31 Dec 2028 23:59:59 UTC (expires in 6 years)
Key RSA 4096 bits (e 65537)
Issuer AAA Certificate Services
Signature algorithm SHA384withRSA

Please share the confidential information via anonymous upload:
ownCloud Enterprise Edition

It’s only accessible for employees of ownCloud GmbH.

1 Like

Updated on Mac OS today where it works flawlessly from the start using the same server.
Tried in two Debian machines and still no luck

Got it to work now by removing 0\General\CACertificates from owncloud.cfg