Debian package conflict. How to update owncloud?

9.1.x
webserver_issue
help

#1

Hello,

I have a problem with my owncloud server (on Apache). For many years, the updates via aptitude went fine and I always had the latest owncloud verison.
However, now I can't update owncloud, because there are package conflicts if I try to do so. It seems that owncloud becomes incompatible with its own packages.
When I try to mark it for installing, the aptitude problem resolver will give only dumb suggestions like deleting the owncloud package.

I have Debian 8.
Owncloud is currently 8.1.9

aptitude writes following (translated from German)

Depends from (2)
-- owncloud-deps-php5 (>= 9.1.4) | owncloud-deps (not satisfied)
-- owncloud-files (>= 9.1.4) (not satisfied)

Packages which are dependent from owncloud (2)
-- Upgrades
owncloud-apps
i owncloud-apps 0~~20141022-1
-- Depends on
i owncloud-apps 0~~20141022-1

Versions of owncloud (4)
p 7.0.4+dfsg-4~deb8u3
p 7.0.4+dfsg-4~deb8u4
i 8.1.9-12.1
p 9.1.4-1.1

As soon as I mark owncloud as update, I get following conflict at package owncloud-files

Collission with
--- owncloud (<= 9.0.99)
-- owncloud-config-apache (<= 9.00.99) (not satisfied)
-- owncloud-server (<= 9.00.99) (not satisfied)

But isn't owncloud-config-apache and owncloud-server what I need???? Or is that now everything in the owncloud package?

Following configuration seems to work, but I am anxious about executing it:

-- Packages which are automatically installed, to avoid depend conflicts:
piA owncloud-files
-- Packages which get installed
pi owncloud-deps-php5
-- Packages which get removed
id owncloud-config-apache
id owncloud-server
-- Package which get updated
iu owncloud


#3

There is an open bugreport about this reported to the maintainer of that package available here:


#4

And what do I need to do now?
I am suffering from a bug and I really need the new OwnCloud version.


#5

You need to wait until the maintainer of the package is noticing this bug and fixing this broken dependency.


#6

Hello,

thank you for your reply.

I have send a bugreport to the Debian BTS ( https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg1500098.html ) and they sent me following reply:

"There is no ownlcoud package in Debian anymore exactly for a (different) upgrade problem; so it's hard to think this is a problem to be reported to Debian's BTS.
Please bring it to whoever is providing you the package."

I am not sure where my packages come from. I think I do receive them from OwnCloud directly.
So what's wrong here?

Here are my files:

/etc/apt/sources.list

deb http ://security.debian.org/ jessie/updates main
deb-src http ://security.debian.org/ jessie/updates main

deb http ://ftp.de.debian.org/debian jessie-updates main
deb-src http ://ftp.de.debian.org/debian jessie-updates main

deb http ://ftp.de.debian.org/debian jessie main contrib non-free
deb-src http ://ftp.de.debian.org/debian jessie main contrib non-free

/etc/apt/sources.list.d/owncloud.list

deb http ://download.owncloud.org/download/repositories/stable/Debian_8.0/ /


#7

Also, my package "owncloud" says:

Maintainer: jw@owncloud.com

(see also my screenshot)

and, also on my screenshot it does say that it depends on owncloud-deps (which is wrong according to the bugreport you showed me)

So it seems it is the official OwnCloud package I have, and it is wrong!


#8

Exactly, thats why i have pointed you already to an existing bugreport to the ownCloud packager above [1].

[1]


#9

Seems that got fixed now:


#10

Hello,

I've updated the package information from the repository, and I can verify that this fix was implemented.

But I still can't upgrade.

Here is the problem:

owncloud depends on owncloud-deps-php5 and owncloud-files.
-- Both dependencies are not satisfied on my computer.

Ok, so I mark owncloud-deps-php5 for installing.
But when I do this (or if I directly mark owncloud-files for installing), I get another conflict.

The to-be-installed package owncloud-files is now broken.
It colldies with the packages owncloud-apache-config (<= 9.00.99) and owncloud-server (<= 9.00.99).

Again my question: Are owncloud-apache-config and owncloud-server not important anymore (i.e. will they be replaced by the package owncloud)? Or will I break my server if I remove them?


#11

There are only the following packages provided by the official repositories:

owncloud
owncloud-files
owncloud-deps-php5
owncloud-deps-php7

Everything else are 3rdparty / outdated / whatever.


#12

On a somewhat related note, I ran into a package issue when upgrading from 9.1.6 to 10.0.3 on Debian 8 and posted my solution here: https://central.owncloud.org/t/upgrading-from-9-1-to-10-on-ubuntu-16-04/8048/5