Default keyring passwd entry required at boot time on RaspberryPi


#1

ph1l asked this same question in Nov '16, but I didn’t see an answer.

I have the Latest Desktop Client (2.4.2?) installed on Raspberry Pi-3. It always prompts for the Default keyring passwd at boot. I want to run the Pi headless, but this prompt requires manual intervention for passwd entry every time the Pi reboots, like after a power hit. The Pi is hosting the OwnCloud server too if that matters. Since this Pi is running Raspbian Stretch, it uses Gnome-keyring, but does not have the Seahorse UI for actual password management like Ubuntu has.

  1. Is there a way to prevent the passwd request, or auto-answer this passwd prompt at boot time like is done for the user account, which auto-logs-on at boot time?
  2. Or is there a way to tell OwnCloud to save its connection passwords in the Login keyring rather than the Default keyring so that the user login, which enables access to the Login keyring will suffice?

#2

Maybe you can find some information about the used gnome-keyring how it is possible to get it unlocked during the login that it can be used by the ownCloud client without asking you for a password?


#3

Thanks for the recommendation tom42. There doesn’t seem to be much documentation. It’s mostly APIs but not much command-line access. I was hoping someone else on this forum might have done this and could help me out. Still looking…


#4

Hey,

have you tried to look outside of the ownCloud documentation for a possible solution? From what i know the sync client is just using whats provided by the operating system and the underlying libraries.


#5

Yep. I’ve been looking for a while without much luck. As noted, there are plenty of APIs, but I’m not writing code. The man pages for gnome-keyring and gnome-keyring-daemon provide a few command-line options, but nothing useful in this regard. I eventually decided that since this server is inside my firewall and never intended to be visible outside of it, that the Pi will use auto-logon when it boots. Then, I deleted the “/home/pi/.local/keyrings/Default.keyring” file and rebooted. When prompted to create a passwd for the Default keyring, I left the passwd field blank. Now gnome doesn’t even bother to ask for a keyring password when the OwnCloud client tries to retrieve its connection passwd from the keyring at boot time.

Yes. I know. This is very poor security policy. But as noted, the server is not exposed outside of 192.168.x.x, so passwords are more of a nuisance than a benefit. There’s a suggestion somewhere out there (I thought it was within the OwnCloud documentation, but I can’t find it just now) to pipe the password in somehow, but that’s only marginally more secure than having no password at all.

Thanks for your suggestions.