Desktop client 2.8.2 not opening on macOS Big Sur 11.4

Installed on Big Sur 11.4 using downloads page. Synced with server fine. However, desktop client no longer opens up so I can’t change which files/folders are synced. Tried uninstalling and reinstalling multiple times. Even after fresh install, desktop client does not open at all (the icon just sits in the dock).

Tried using homebrew install but same issue encountered.

Please don’t use the homebrew client, please use the regular from the ownCloud download page

Then please start the client from Terminal using this command, and post the last ~30 lines of the output:
/Applications/owncloud.app/Contents/MacOS/owncloud --logdebug --logfile - --logflush

When running the command:
/Applications/owncloud.app/Contents/MacOS/owncloud --logdebug --logfile - --logflush
the icon appears in the dock and then disappears. No output is written to the terminal. I can’t find any logs in the directory structure either?

Interestingly though, if I just run:
/Applications/owncloud.app/Contents/MacOS/owncloud
the application launches correctly as expected. However, if I use the launchpad shortcut then nothing happens and owncloud does not launch.

That sounds like the application is already running, in that case we won’t show any output.
If you also pass -s in addition to --logfile it should raise potentially existing windows.
You could also make sure that owncloud is not listed in the Activity Monitor.