Desktop Client does not update local file if opened in Excel, Word or Powerpoint

possible_bug
help

#1

Steps to reproduce
1. Create a Microsoft Office file (Word, Excel Powerpoint, doc, docx, xls, xlsx, ppt, pptx, ...) and upload it to Owncloud
2. Sync the file with the Owncloud Desktop Client to a Windows PC
3. On the Windows PC: Open the file in the local file system with Microsoft Office (Word, Powerpoint or Excel) - without changing anything
4. Change the file on the server during the file is still opened in the local file system (from another PC or upload a changed file with the same name to the web frontend)
5. Close the file in the local file system (close the Microsoft Office program)

Expected behaviour
The desktop client should update the file in the local file system with the changed version from the server .

Actual behaviour
The desktop client does not change the file in the local file system. But the activity protocol in the desktop client says that the file is downloaded.
In reality nothing happens, even when you wait longer. No update happens if you close the local copy. Also it is not possible to force an update or any information of a sync conflict.

Client configuration
Client version: 2.2.3 (build 6307)
Client operating system: Windows 10

Server configuration
Operating system: Ubuntu 14.04.5 LTS
Web server: Apache/2.4.7 (Ubuntu)
Database: mysql Ver 14.14 Distrib 5.5.50
PHP version: PHP Version 5.5.9-1ubuntu4.19
ownCloud version (see ownCloud admin page): 9.0.4
Updated from an older ownCloud or fresh install: Updated
ownCloud log (data/owncloud.log): nothing special

Special configurations (external storage, external authentication, reverse proxy, server-side-encryption): NO

This behaviour was discussed here in 2014 - but it is still not solved:
Files in local folders not being updated
https://forum.owncloud.org/viewtopic.php?t=22299


#2

Issues discussed here at central or at the old forums are unlikely to be fixed as they are mostly gets lost in between all the other stuff discussed in here. Please report such stuff directly to the sync client developers at https://github.com/owncloud/client/issues


#3

Thank you for your advice. I opened an issue in github: https://github.com/owncloud/client/issues/5190