Desktop client fails connecting via https


#1

Hi,

I switched my server (php 7.0, oc 9.1.6) to https.
Now my desktop client (os x 10.12.6, oc 2.3.3) is no longer connecting to the server.

The client reports:
'Error transferring http://cloud.domain.de/remote.php/webdav/ - server replied: Bad Request'

I tried to change the URL from http://... to https://... but I can't find an option to do so.
If I click on the existing URL which is shown by the desktop client the web browser login opens via https!

Did I missed to do something? Is there a simple! manual how to set the system to https?

greets


#2

Hi,

How die you switch? Is your server still reachable via http or only via https?

Have you tried deleting your account in the sync client and enter the https address in the new account configuration?


#3

Hi dmitry,

thank you for response.

If I setup the server just to accept https it is like I discribed.
If I allow both, http and https, the client still connects to the server.

I did not delete my account, because I want to avoid that I have to sync all data on every client (several pc's with several accounts) again.

What I don't understand is, that clicking on the http-URL shown by the desktop client ( and which is marked as unsecure) leads to a https-connection via the web browser. But the desktop clients does not connect.


#4

Did you use a self signed certificate or let's encrypt?


#5

I used let's encrypt


#6

Did you follow this guide?

https://doc.owncloud.com/server/10.0/admin_manual/configuration/server/harden_server.html?highlight=web%20server#use-https


#7

so, I am back.

Well, as far as I could, I followed this guide.
To explain, I do not own the server, it's a rented one.

The server provides a UI to configurate the SSL certificate.

First I installed a dedicated domain as subdomain for owncloud as recommended:
cloud.domain.de

I installed an own Let's Encrypt certificate for this subdomain.

With the UI I activated SSL, I activated to force SSL and I activated HSTS max-age 15552000.

After that, the issue occured.

........

Today I created a new account beside the old one with the oc desktop client.
I used the same user name and the same url, but I put https in front.
And voila! It is working.
The client checked all data but could not found changes, so there was no must to exchange data.
Everything was sync in a minute and I deleted the old account.

so, it seems to me that there is no way to change to https with the old http-account. It's a must to create a new account with https. That is what you recommend at first!

ThanX

dinges


#8

... and now I did the same on another PC with an other account.
it happend, what I wanted to avoid. OC is syncing everything new, which takes hours.

is this the official workaround? I can't belive that.


#9

But if you are now on another PC with a different account - is that not the usual behaviour that it will sync everything new?


#10

hm. I think no.

I have different accounts connected to different devices.
Now I have to change every desktop applikation on each client to the new https.

with one of my accounts on two devices - as I described - it worked without downloading every data new.
with the other account on two further devices it just worked for one device. On one of these two every data downloaded again. This took a few hours.

there is just one device left which I have to change to https. I will see what wil happen.