Desktop Client reports "Server Version 9.1.4.2 is unsupported!"


#1

Hi everyone,

With oC desktop client version 2.5.0 (build 10560) a warning message is shown on top of the settings window: “The server version 9.1.4.2 is unsupported! Proceed at your own risk.”. In addition, a similar warning message is shown in the windows message center.
For the rest the desktop client and the file synchronizing work properly.
I realized this behaviour after update to server version 2.5.0. Before this, no warning occurred.

By the way, at other desktop client installation with previous vers. 2.4.3 (build 10188) everything works properly, without any warning message.

Are any issues known regarding malfunction between server version 9.1.4.2 and client version 2.5.0?

Thank you for any helpful hints in advance.

Regards,
August

Server configuration: not known (not under own administration)

ownCloud version: 9.1.4.2 (assumed)

Client configuration

Client version: 2.5.0 (build 10560)

Operating system: Windows 10 Home 64 bit, Vers. 1803

OS language: German

Installation path of client: C:\Program Files (x86)\ownCloud

Logs

  1. Client logfile: no relevant logs

  2. Web server error log: not known

  3. Server logfile: ownCloud log (data/owncloud.log): not known


#2

pre-10 ownCloud server versions are EOL for a long time and weren’t tested with the 2.5.0 clients. They also don’t send checksums to verify data doesn’t get corrupted, and they don’t log the X-Request-ID's to easily debug issues.

This means oC team isn’t aware of serious issues, but they also can’t detect them and they can’t debug them.


#3

I had same issue. Updated server version 4 days ago to 10.0.10.4 and all good now. No other solution exists other than to downgrade client to 2.4.3 again, but that doesn’t work well if you have a large user base like me.


#4

Hi Michael and Andrew,

thanks for your helpful replies. I also assumed that the oC client version is outdated. I will talk to the admin of our NGO in order to update oC client.


#5

Hi,

maybe i’m wrong but from what i understand you don’t need to downgrade the client if you already have updated the server to the latest release?


#6

Downgrading only required if server stays at 9.1.8. Apologies for not writing clearly.