Desktop Not Logging In

help

#1

Hello, I am new to OwnCloud. I am trying to get everything setup and on the Mac desktop app, it is not connecting. I have put the password in a few times and nothing. "Access forbidden by server."


#2

Can you log in to the web interface? What about using the ownCloud client on other Operating Systems, like Windows or Linux?


#3

So, I can log into the portal and I see two folders with a few images and a sample file. I haven't tried logging in from a device, but I am getting the same thing on the Windows app.

I also have these errors:

  • The PHP module 'fileinfo' is missing. We strongly recommend to enable this module to get best results with mime-type detection.
  • Some files have not passed the integrity check. Further information on how to resolve this issue can be found in our documentation. (List of invalid files… / Rescan…)
  • cURL is using an outdated OpenSSL version (OpenSSL/1.0.1). Please update your operating system or features such as installing and updating apps via the app store or Federated Cloud Sharing will not work reliably.
  • You are accessing this site via HTTP. We strongly suggest you configure your server to require using HTTPS instead as described in our security tips.

Not sure if that has something to do with it.


#4

Are you logging in to the web interface with the same credentials that you're putting into the clients? Is the hostname or IP address that you're using correct? Definitely fix the file integrity check error.


#5

I setup app passwords for each.

However, I just took the whole thing down. I am on a VPS (virtual private server) and I don't have access to the PHP files. So, instead of treating this like a server install, I am redoing the install like a shared hosting install.


#6

Well, I did that. The file integrity error went away, but the other three errors are still there.

Also, when I go to install the application (using either method) it will not connect using MySQL. According to my hosting provider, I can't input "localhost", but rather it needs to be set to "mysql.domain.com". When I enter my domain, it tries to default to my VPS address (123456.hostaddress.com).

The good news is that I am now able to connect with via the app on the Mac and I can still see the files in the online portal.

Is it possible on a shared hosting install type to move to MySQL? It is supposed to be better for what I need to do.


#7

Which client version?
Which server version?


#8

On that, I am really not certain. Whatever I downloaded from the site yesterday.

Because I switched to using the hosted installer, I am no longer seeing the same error.