Desperately need help getting cron set up correctly on Univention appliance

Hi everyone. I am a Windows system administrator but I don’t know much about Linux. My work wanted me to set up Owncloud for our handful of offsite employees and so I downloaded the Univention appliance. We are a super small company and my boss won’t spring for an enterprise license.

I was able to connect our Windows SMB share to it and give our people offsite access. Everything looks good except I can’t get the scheduled cron jobs to correctly run. When I move a file into the shared folder on the server it does not automatically get detected unless that user visits the Owncloud web portal and navigates to that folder. We only use the desktop client and we don’t use the web site at all which pretty much excludes that option.

In another topic I was educated enough to realize that I need to schedule a cron or listener job and I’ve spent around 30 hours trying to do exactly that with zero success. I’ve learned a ton about Linux and how Docker works but this is still way beyond me.

I’ve tried running scheduled cron jobs which was confusing because there are 13 cron.php files scattered in this Docker app and I can’t figure out which one to run. I ultimately ran all 13 of them in crontab every minute but it obviously did not fix the issue. I also tried to set up a listener using this command:

/usr/bin/univention-app shell owncloud occ wnd:listen -vvv bbrserver “Company Data” administrator (password)

But regardless of whether I use root or www-data it throws me a bunch of different error messages including:

In Application.php line 564:

There are no commands defined in the “wnd” namespace.

If this doesn’t get resolved I’m positive that I’m going to get fired. Desperation is kicking in and I will pay someone here out of my own pocket if they can help me get this set up. We can do a screen share and a phone call and I will paypal you or use whatever other payment processor you want.

It’s so frustrating because everything else works perfectly but this one little function is a dealbreaker. I really really hope someone can help me out as I’m pretty much toast without help.

Here’s what I did in my singularity container:


*/15 * * * * <username> /opt/rh/rh-php72/root/bin/php -f /var/www/html/owncloud/cron.php

– where <username> is an account with appropriate access –
to a new file in /etc/cron.d/. I called it owncloud because I’m super creative :wink:

I also had to do a chmod on the file:

chmod 644 /etc/cron.d/owncloud

and add

crond -s

to the container startup to start the cron daemon.

I have no idea what the Univention appliance is, but it sounds container-esque, so I hope this helps.

Best of luck!

1 Like