Direct download has changed!

Hi,
we experience a problem with direct download links. Previously direct download links for PDFs were initiating immediate download and now they open the PDF in a browser. Why? How can we prevent it?
Also now other files after being downloaded have a changed name into: ‘download’. What happened?

Steps to reproduce

Expected behaviour

Tell us what should happen

Actual behaviour

Tell us what happens instead

Server configuration

Operating system:

Web server:

Database:

PHP version:

ownCloud version: (see ownCloud admin page)

Updated from an older ownCloud or fresh install:

Where did you install ownCloud from:

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

or 

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/…

Are you using encryption: yes/no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…

LDAP configuration (delete this part if not used)

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';


Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration

Browser:

Operating system:

Logs

Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

Isn’t this a browser feature that can be turned off?

2 Likes

No, it’s not. It happens to me as well and I haven’t changed anything with my browsers. I wonder if something was changed in the last OwnCloud update?

Or maybe the browsers default behavior was changed by its last update.

  • With the little to none information you’ve provided it’s impossible to help. There is a template asking for basic information which is important to fill as much as you can in order to have an idea about your setup.
  • As far as I know, there is no “direct download” feature, or at least I don’t know anything with such name. As said in the previous point, it’s impossible to help if we don’t know what you’re doing
1 Like

I assume you’re using firefox, because this sounds very familiar. If it is Firefox then it’s a browser option/feature. You can disable it under Options -> General -> Applications -> PDF (see image). Firefox does set PDFs to auto open in browser when it updates sometimes.

1 Like