Distributing Windows Client via GPO fails


#1

Hi!

I’m trying to deploy the latest Windows client 2.5.1 via Windows server group policy deployment, yet the client fails to install. On the computer, the installation begins but fails immediately.

I get these entries in the system eventlog:

Event 301 (Information)
The assignment of application ownCloud 2.5.1 from policy Deploy OwnCloudMSI succeeded.
Event 102 (Error)
The install of application ownCloud 2.5.1 from policy Deploy OwnCloudMSI failed. The error was : %%1605
Event 303 (Information)
The removal of the assignment of application ownCloud 2.5.1 from policy Deploy OwnCloudMSI succeeded.
Event 108 (Error)
Failed to apply changes to software installation settings. Software changes could not be applied. A previous log entry with details should exist. The error was : %%1605

I’ve tested this on a vanilla Windows 10 1803 64 bit as well as on a Windows 7 SP1 32bit, no difference
The MSI installer logs don’t show any apparent errors, I can provide them if needed.

I can install the MSI manually on those computers as an admin though

I can also rule out file access problems on the repository, I distribute several other software as MSI from there successfully (iTunes, Adobe Reader, Flash, Java to name a few), same goes for the policy itself, using the same settings for that policy like all others (ignore language, install on 32 and 64 bit machines)

I even tried to do an administrative install (msiexec /a msiname.msi), but this didn’t work either as I wasn’t even asked where to install to…

Any hints for a solution are welcome…

Edit:
I was able to test an administrative Installation as source (using the TargetDir parameter), but I get the same errors in the eventlog…


#2

What is the exact name of the MSI file you used? Did you try the single-language MSI?


#3

I was using the msi from this page:


I’m not aware of any other, non-beta sources.


#4

Hm, it’s not linked on websites. Needs to be fixed…

Here you can find the single-language *.MSI’s that are required for some GPO deployments:
https://download.owncloud.com/desktop/stable/?C=M;O=D

I’m not a GPO expert, but I remember we’ve got feedback about GPO issues with the multi-language *.MSI. Here you can find the related discussion:
https://github.com/owncloud/client/issues/6769


#5

Thanks Michael, the en-us version of the MSI installed flawlessly on the first try. Problem solved.

Now I have to clean up my own mess when I used a MSI-wrapping tool to distribute the pre-2.5 versions and have to find a way to switch over to ‘real’ MSI files…