Doing update from 9.0.1 took down my server

reported_bug
9.0.x
help

#1

This happened several times in a row today. Each time I tried to update from 9.0.1->9.0.4 (by clicking the button in the admin module), nothing appeared to happen.

But, then MySQL crashed, as well as cPanel and a bunch of other Linux services. CRASH!

After restating the services and verifying all was stable, I waited a bit then clicked the owncloud "Update" button again. Same result. MySQL--> DOWN, as well as other services. And, my .htaccess file in another site had a "_" appended to it taking that site down, too.

Therefore, I did a virgin install of OwnCloud, but now I'm afraid the next time there will be an update to do. I can't spend an entire day installing owncloud, changing the database to MySQL, and all the other ancillary tasks, PLUS, restarting all the services on the server as users are calling me asking why their sites stopped working.

Hopefully, this Update issue was just a bug in the 9.0.1 release, but I wanted to mention it as it has taken about 7 hours of my day to get everything back up and running.

Look forward to any ideas on what might have happened.

  • m

#2

When you open a topic in Help/OwnCloud 9.0 it normally shows you a template to provide important information. You need to share more information about the system and from your logfiles.

If it is your own server, the manual update method is more reliable especially when you run the update itself via terminal (occ-command):
https://doc.owncloud.org/server/9.0/admin_manual/maintenance/manual_upgrade.html


#3

Sorry, i had moved the thread here to help as the user posted in "uncategorized" which seems have some issues with the topic templates. Currently in the way to fix this.


#4

I had the same issue, tried to run the update 9.0.1 to 9.0.4 from the admin page. The server stopped working. After looking into it I noticed there was 1700+ instances of occ running on the server and overloading it. after rebooting the server i was able to access it, but still not able to update. hope there is a fix soon.

11377 ebfile 20 0 184m 5044 372 S 0.6 0.1 0:00.50 php /home/ebfile/public_html/occ --no-warnings config:list --private --output json


#5

Please report that directly to:

https://github.com/owncloud/core/issues

Its very unlikely that there are any fixes if this is not reported at the bugtracker.


#6

Thanks for the recommendation,
I just reported the issue.

@overflow I wonder if you're having an overload issue also.
Did you find out why your server crashed.


#7

Not really, but running the installer had the following effects:

  1. Crashed cPanel
  2. Crashed MySQL,
  3. Crashed about five other services

Never had this issue before with the server, nor since I did the update manually.

Then, after trying to run the update -- a totally separate domain had its .htaccess file appended with had a "_" rendering site navigation useless ("Page not found on this server" type errors).

After I read your latest posting I did a "ps- -ef" on the server, but didn't see any OCC processes.

Not sure what the bug is but it is super bad.

Hope they identify/fix it before 9.1.1, or whatever.

Thanks!

-- o


#8

Ref: